Which 2.5.1 release to use?


#1

I noticed there are a number of release candidates for 2.5.1: https://github.com/OpenROV/openrov-software/releases

But the order is odd: I see RC3 first, then RC4, then RC5, then RC2.

Normally I would expect RC5 to be the latest, yet if I go by the date listed, it seems like RC3 was released most recently.

Which one should I install?


#2

Agreed. I've managed to confuse github. Use RC5. It is the latest.


#3

Super, thanks Brian.


#4

I'm going to install 2.5.1-RC5 now, however the naming of the "boots from SD card" (OpenROV-2.5.1-95.img.7z) and "copies SD card to flash" (OpenROV-flash-2.5.1-36.img.7z) spook me: why is one -95 and the other -36? Are they really exactly the same release, just that the 2nd one copies itself to flash? Or is the flash version older?


#5

I have problems with this version on my V2.6 rov.
No video and compass isn't working....

Shall I go back to the latest stable version...2.5.0 -29?


#6

Hmm, video works for me after upgrading, and the experimental depth hold seems to work quite well. I do wish there were a "hold depth at 0.3 meters above the bottom" feature :)

I did the upgrade via "write to SD card, copies to emmc on first boot".

I installed the simple theme UI plugin (http://community.openrov.com/forum/topics/theme-simple-theme) and it's very nice.

Our compass seems to move all over the place ... though I think it was doing this before we upgraded too. I'm not sure if there are magnets in the bottom of this pond, or if there's a software issue somehow, or if the magnets in the motors interfere (though another thread seemed to indicate they do not)...


#7

Are you using 2.5.1 - RC1 or RC5?


#8

I'm using 2.5.1 RC5.


#9

Damn, When I use the RC5 version...everything works now except video :(
When I shift to 2.5.0.29...everything works...except I can not use the logitech gamepad :(

Damn...why is everything so unstable??


#10

Hello,

Try this for the video problem.

If the camera does not load you can restart cockpit which will also restart the video process. This can be done by logging into Dashboard (192.168.254.1) and then clicking "stop" under cockpit and then wait a few seconds and then clicking "start." Give the ROV about 30-60 seconds to boot up cockpit and then when you go to cockpit (192.168.254.1:8080) the video should be working.

-Brian Grau


#11

Worked like charm :)

My Logitech 710 wireless gamepad works to :)

No my little problem is to get the "Simple Theme" to stay in the plugin folder. After I reboot the ROV it is gone from the folder....