Webcam testing


#1

Hi,

i have the cockpit running, and attached an old webcam in order to test.

Do you need the cape to see an image allready?

The cape is stuck at customs at this moment... so have to wait..

thx

frank


#2

Frank,

I think you should be able to see an image in Cockpit with only the BeagleBone and your webcam. Have you tried this already?

Eric


#3

Hi Eric,

I allready tried this, but i get the "no image" image...

It is really an old cam, maybe there is the problem?

i also installed the image again, with no modification whatsoever.

frank


#4

Hi Frank,

I just tested my WebCam with BeagleBone , No need to have the Cape board yet,

One thing that I found out that the Browser that the key,

IE = Did not work ,

Safari = did not work

Google Crome = Worked fine

Firefox with latest updated = Worked

The other thing is the WEBCAM need that brand worked on the Linux, I got one from EBAY same as the BOM list = Genius WideCam F-100 1080 HD which worked perfect, it cost on EBAY for me $50 but you can find from AMAZON for $70 a little bit pricy but it worth for the picture quality.

I tested many of old WEBCAM, most of them did not work.

Enjoy

Nimit


#5

Alternatively, I've tried two different, newer webcams that worked fine. You mihgt try checking the internet settings on your computer; maybe the camera stream (which is on port 8090) is being blocked?


#6

hi,

i tried another cam (trust Full HD 1080P)

this one gave me at first the image, but only once...

this is what i got from the log:

rov@OpenROV:~$ tail -200 /var/log/openrov.log
config { debug: true,
debug_commands: false,
production: true,
sample_freq: 20,
dead_zone: 10,
video_frame_rate: 15,
video_resolution: 'SVGA',
video_device: '/dev/video0',
video_port: 8090,
port: 8080,
serial: '/dev/ttyO1',
serial_baud: 115200,
OpenROVCamera: './lib/OpenROVCamera',
OpenROVController: './lib/OpenROVController',
FirmwareInstaller: './lib/FirmwareInstaller' }
info: socket.io started
Starting the script from /opt/openrov/src/linux to setup UART1...
Started listening on port: 8080
path.existsSync is now called `fs.existsSync`.
initiating camera on
/dev/video0
spawning capture process...
emitted 'videoStated'
camera started
stderr: MJPG Streamer Version: svn rev:
i: Using V4L2 device.: /dev/video0
i: Desired Resolution: 800 x 600
i: Frames Per Second.: 15
i: Format............: MJPEG
i: The format asked unavailable, so the width 640 height 480
Adding control for Pan (relative)
UVCIOC_CTRL_ADD - Error: Invalid argument
Adding control for Tilt (relative)
UVCIOC_CTRL_ADD - Error: Invalid argument
Adding control for Pan Reset
UVCIOC_CTRL_ADD - Error: Invalid argument
Adding control for Tilt Reset
UVCIOC_CTRL_ADD - Error: Invalid argument
Adding control for Pan/tilt Reset
UVCIOC_CTRL_ADD - Error: Invalid argument
Adding control for Focus (absolute)
UVCIOC_CTRL_ADD - Error: Invalid argument
mapping control for Pan (relative)
UVCIOC_CTRL_MAP - Error: Invalid argument
mapping control for Tilt (relative)
UVCIOC_CTRL_MAP - Error: Invalid argument
mapping control for Pan Reset
UVCIOC_CTRL_MAP - Error: Invalid argument
mapping control for Tilt Reset
UVCIOC_CTRL_MAP - Error: Invalid argument
mapping control for Pan/tilt Reset
UVCIOC_CTRL_MAP - Error: Invalid argument
mapping control for Focus (absolute)
UVCIOC_CTRL_MAP - Error: Invalid argument
mapping control for LED1 Mode
UVCIOC_CTRL_MAP - Error: Invalid argument
mapping control for LED1 Frequency
UVCIOC_CTRL_MAP - Error: Invalid argument
mapping control for Disable video processing
UVCIOC_CTRL_MAP - Error: Invalid argument
mapping control for Raw bits per pixel
UVCIOC_CTRL_MAP - Error: Invalid argument
o: www-folder-path...: disabled
o: HTTP TCP port.....: 8090
o: username:password.: disabled
o: commands..........: enabled

any ideas?

regards

frank


#7

The line "i: Desired Resolution: 800 x 600" is a little odd. I think the config file should default to 1920x1080.

Maybe try going into config.js (/opt/openrov/src/lib/config.js) and changing line 33 so it looks like this: video_resolution: process.env.VIDEO_RESOLUTION || '1920x1080',


#8

I think the higher resolution was implemented in a more recent update to the code. That being said, if you're still having trouble with the code try downloading the newer stuff from http://github.com/OpenROV/openrov-software. The errors you were getting are related I believe to mjpg-streamer; I think there may be some inconsistencies with different versions.


#9

Hi Guys,

thx for the update, i will test it tonight.

Frank


#10

Hi Again,

i tested it yesterday evening, the cape upgrade was ok, i

have process.env.VIDEO_RESOLUTION || '1920x1080', now,

but the arduino part says that the version is incompatible.

when i download the new firmware via the cockpit, i can select the file but then when pressing update, nothing happens...

i do not have the logs here but will provide them if needed

any ideas?

frank


#11

Hi again,

since i am a linux noop, i guess the problem has to do with rights on the arduino part

is there a chmod command that enables 777 on the whole disk?, so with putty, i connect with user ROV and then, from that root edit the rights to the whole image?

google is not my friend in this case...

regards

frank


#12

Hey Frank. Per the item you were seeing in the log. When the system first starts it won't send commands to the Arduino until the Arduino reports back a version number. It usually takes a few seconds in which case you might see these.

The Arduino firmware is not used for video at all.

As far as having permissions go... the 'sudo' command is your friend 'sudo <command to do something as administraor>'. I have no idea what might go wrong with a disk wide chmod of permissions.


#13

Hi,

i will post the logs tonight, maybe it will be more clear then

frank