Water damage assessment


#1

Hi all,

Long story short: I have had water in the electronics compartment. If I connect to the beaglebone directly using a usb-cable the BBB seems to boot up alright (the blue LED’s flash in the same pattern as they normally do (wave-form). If I connect it via the twisted pair however it doesn’t boot up at all and only the ETH and PWR LED’s on the motherboard flash together. Could you help me troubleshoot?

Best regards,
Reinhout


#2

Sorry to hear of your problem.
I think others would agree, firstly, it would help us to understand the problem if you could let us know the conditions of the flooding, and what remedial action was taken.

Eg. 1) How long ago did the incident occur?
2) Was the flooding in fresh, brackish or sea water?
3) Approximately how much of the tube was filled?
4) What drying procedure was used and over how long?

Anything else you can contribute would give others a better picture to help you.

Best of luck.


#3

I’m evaluating the OpenROV for educational purposes for a navy. I did a test in a swimming pool with a model 2.6. I followed the predive procedures and tested all commands just below the surface of the water. I have done small tests in the past at lesser depth (0.8m or 0.08bar) without a problem I also had an extra person ready to help me.

I brought the ROV to a depth of 1m and activated the depth control. I added ballast so the robot has a neutral buoyancy. I saw the depth control react towards the vertical axis motor so I prepared some camera’s. By the time I had started my 2 camara’s my aidman called me to ask at what depth I had set the ROV. I saw it go to a depth of about 2m without reaction of depth control.

I then disengaged the depth control and hit shift to manually move it upwards but the robot didn’t react. My aidman then jumped into the water and recovered the ROV.
Time submerged: about 3 minutes. Time from losing the controls: about 1 minute or less.
I emptied the tube, unplugged the twisted pair cable (no reaction from the ROV electronics), removed the batteries and wiped the electronics with a towel.

I then disassembled the electronics and let it dry on a towel in a warm room (close to a water heated radiator and in the sun). In the mean time found out the water was coming in through the hole in the endcap (where you insert the little rubberised plastic plug). This was the first time the robot was tested in a pool. I’m strict on following the pre-dive procedure (military background) so I’m really disappointed at how things turned out. Maybe the person who made the robot did a bad install because previously I also had problems with the battery tubes. A skilled person got us thicker tubes (the original ones were not perfectly round) and made the endcaps out of one piece. We tried a number of things to get the main container watertight after the incident last week but in the end I filled the hole with epoxy.

Now I can let the BBB boot up (normal wavelike pattern from the blue LED’s) but I can not connect with the twisted pair cable.

tl;dr:

  1. Last week
  2. Fresh swimming pool water (with Cl, not salt)
  3. The tube was filled approx 25% for about 1 minute, pressure went from 0.1 bar to 0.35 bar during the sinking.
  4. Water removed from tube, connection on twisted wire cut immediately, batteries removed. The ROV didn’t react to a shutdownsignal when I removed the twisted wire.

I did not dare to use an aggressive drying procedure so I disassembled the electronic parts, dried them with a fresh towel and lay them on another towel in a warm room close to but not directly above a water heated radiator.
I let the electronics sit for about 48 hours. I reassembled everything and connected an usb-cable to the BBB. It just booted up (the blue LED’s follow a wavelike pattern).
When connecting via the twisted pair cable however the BBB doesn’t boot and the Arduino just flashes it’s ETH and PWR LED’s. I also hear a silent click when the LED’s flash on and of (like a relay engaging and disengaging but far more silent).

Thank you for your help!


#4

Hi, I am sorry nobody answered…
Were you able to make it work again?
You said you just dried all electronic parts with a towel, can you tell me if that procedure was enough to save your rov?
Thanks


#5

Can you tell me what happened with your micro SD after that? You needed to have to configure it from the beginning?
Did the camera worked?

Thanks for answering…