VLC Streaming is not working


#1

I have connected my rov and the cockpit is working with the URL:192.168.254.1:8080.However, after I enter the streaming URL:192.168.254.1:8090/?action=stream (I followed the steps in the guide) in the VLC player the video does not stream in. Anyone can help me with this?


#2

For vlc you will need to include the http://

Dropping the http:// will work in the browser as it just assumes that is what you are after, but VLC needs to be told whether to connect rtp/rstp/udp/tcp/http… etc.

In case you are interested, you can also use VLC to transcode and record the stream (laptop needs a little bit of grunt for this) on the fly by running a command like:
vlc.exe http://192.168.254.1:8090/?action=stream :dshow-adev=“None” :dshow-fps=10 --sout=#transcode{vcodec=mp4v,vb=1024,scale=1,deinterlace}:duplicate{dst=display,dst=standard{access=file,mux=mp4,dst=.mpg}} vlc://quit

Just replace with whatever you want to call it (or call the command from a batch file and pass the date/time as the filename).


#3

For if/once you get VLC to work with the stream…In my case, VLC would crash whenever I tried to record the stream. For a few dives I just used Screencastify, but just recently I found the program iSpy that works with VLC to record a webcam stream. Works like a charm! All you have to do is move all the VLC files (or extract directly to) a folder within the iSpy directory (they give directions), set up where VLC should take the stream from, then copy that info into iSpy when you add a camera.

If you’re not able to record with VLC and go this route, be sure to install the same version of iSpy as VLC! That is, if you install the 32 bit VLC, also install the 32 bit iSpy…same for 64 bit.


#4

Hi, Adam I tried enter http://192.168.254.1:8090/?action=stream but in the end the video still never stream in, but thanks to mccullermi the program iSpy works! Thanks for all the suggestions.