Video Export Trouble


#1

I seem to be having some video export issues on my Nvideo Sheild K1 tablet. When I go into “Past Dives” in the Cockpit app the videos all play just fine in there. I then go to export and I see the “Exporting Video” followed by “Export Complete” at the bottom. I hit open and it opens up in my video player just fine. I don’t need to export to the cloud at this time, I just want to copy the files from my internal memory to my PC. I connect to my PC and go to the selected export location on my tablet. Some of the files show a file size and some show “0 bytes”. It is interesting that the files show a number for the length of the video but with 0 bytes for size. Today I recorded 9 videos and was only able to successfully export 3 of them. The other 6 still play fine on the “Past Dives” screen.

Anyone else having this type of issue? Maybe specific to the Nvidia Sheild K1 although I tested it on my Samsung Galaxy S7 and the same thing happened. I know that there will be upgrades to the video capture capabilities of Trident software and Cockpit app in the future and I look forward to that. Being able to get the 1080p video off Trident memory will be great! Until then, just would like to be able to get the 720p videos off my tablet.

Here is a screenshot:


#2

Perhaps you could try to copy the different films on a SD card and to transfer by that way.


#3

I also tried to export to the SD card in my tablet and it says “export failed”. I believe that it only has the ability to export to the internal memory.


#4

In fact I suggested that you copy the file, not to save it !


#5

I would very much like to just copy the video files directly off my tablet but I have no idea where they are saved to or even where the Cockpit app directory is located on internal memory. My thought is that they need to be exported so maybe there is a conversion process that needs to happen before a video is available to download.


#6

I am really not an android user but have tried to localize the place where the films are stored.

On my device (the android gamepad sold by Openrov) the place is : android>data>com.openrov>files>data

To find this I have downloaded the free file explorer ES from the Playstore.

Tell us if this helped you !


#7

I have not experienced this issue on my Samsung Galaxy Tab S2.

Video export has been rather straight forward and I have both copied and moved the files to SD card for transfer to PC and backup media.


#8

I took a look in the folder you suggested and I did find files that are the appropriate size for the videos I captured. They are in a file format I have never heard of though as a *.h264 file. There is also an accompanying folder with the same name as the file. See screenshot.

I found no regular video file formats such as the *.mp4 that are created during the cockpit app export process.

What file formats have you seen in the folder?


#9

Was just able to get the *.h264 file to play using these steps and VLC media player.

Now I am going to see if I can get it converted to mp4 or something more common.


#10

Interesting. I’ve seen this error before on older versions of the App. if you’re using 1.3.3 or higher it should be fixed.

The other thing I would try is make sure to export the files into a physical drive. I ran into issues when selecting the given “media” folders such as “photos” “videos” etcetera. To navigate or create folders in the Android environment that mirrors windows more closely you will need to download a file explorer app.


#11

That is interesting that I’m having a problem with this because I’m using 1.3.3

Could you clarify for me what a physical drive is? On my tablet I have “internal memory” and an SD card that I added for additional storage. I have not been exporting to the SD card (although I tried and it didn’t work either). I have also tried exporting files to the root directory of the internal memory as well without success.

What I can’t figure out is why some videos will export just fine but others won’t. Also, the file that is created during export always has a “length of video number” even if the size is zero.

At any rate, I know that change is coming eventually with app updates and at least I know I can copy the files as *.h264 to my PC for now.


#12

Let’s see if we can’t get some help with this…


#13

Hi All,

I just checked the crash reports to look for non-fatal errors that might be related to this class of issues. I came across one report that seems to match up and has only affected Nvidia Shield K1 Tablets so far.

The error message given is a permissions error when trying to write the exported file. The report below matches the date/time of the first recording in your screenshot, so this may be to blame:

Exception java.io.FileNotFoundException: /storage/<redacted>/DCIM/Trident-Apr-15-132404.mp4 (Permission denied)
java.io.FileOutputStream.open (FileOutputStream.java)
java.io.FileOutputStream.<init> (FileOutputStream.java:221)
java.io.FileOutputStream.<init> (FileOutputStream.java:169)
org.jcodec.common.io.NIOUtils.writableChannel (NIOUtils.java:353)
com.openrov.cockpit.storage.blackbox.Export$4.run (Export.java:253)
java.lang.Thread.run (Thread.java:761)

Can you try exporting to a few different locations and see if that makes a difference? The new workflow is only a couple weeks out, so if we can just understand the underlying issue and work around it for now, we can make sure the new version won’t experience the same thing.

Thanks,
Charles


#14

Thank you for the in depth look at the issue Charles. I have tried exporting to other locations on my tablet internal memory but I usually get the same results. Usually the first 3 or 4 videos will export fine and then any others beyond that will export to create a 0 byte file size.

This ins’t a huge issue for me and since the new workflow is a few weeks out that is good news. Could you say if the new workflow will have the ability to capture videos on Trident at a higher bit rate in 1080p and download through the tether at a later time?

Thank you!


#15

Yes, the update for the video subsystem will add the ability to record 1080p onboard Trident. The 1080p stream will support bitrates between 10 and 50Mbps, to give some flexibility in quality vs max recording time. At max bitrate, recording time is about an hour. These videos will then be able to be downloaded after your dive. In the future, we will be working through several methods for making this process as fast and easy as possible.


#16

That is wonderful news! I’ll be looking forward to using the higher bitrates for sure. I like that there is ample storage for recording as well. Thank you for the update on that.


#17

Hi Charles,

I know you said the new workflow is still a week or so out but I could really make a statement at my current job if I was able to capture high quality video for a damaged roadway culvert. In another post I heard of a “beta version” of the Cockpit app that allowed for the Trident internal memory video capture. Is there any chance I could get my hands on this version before Wednesday evening of this week? Sorry for the short notice but if doable, it could really help me out.

Matt


#18

I actually have the same problem. It happens with long/big video files. I have one at 50 mins and one at over an hour.

When I export those in the openrov cockpit, it seems the program crashes or something similar. What it appears to do is that the screen goes blank and the app autologins - then there’s a file exported that’s 0 bytes.

All other clips I have from previous dives are under 30 mins. Those export just fine.

I’m using the JXD controller bundled from OpenROV.

EDIT: Seems one of the videos were still processing - making thumbnails and whatever else it does. Tried to watch it within OpenROV cockpit and got the still processing message.

As soon as the processing was done both video files exported without any issue.


#19

Thanks Ecthelion! Added your observation to https://github.com/halmueller/trident-hacks.