Video became frozen(still scene never changed and no stream) but other worked well


#1

I set up my first dive in a baby swiming pool. When the rov was connected to the cockpit, everything works well. Both the video and other control(motors,led,laser,etc…).However,after 20 second or so, the video froze and never change again, but I could still control the motors,leds and other things. The rov was swimming like a blind fish…I reboot for several times, the situation didn’t change.
My software image is 30.0.3 and I don’t have an IMU moduel yet. The BBB worked well and all the 3 lights on the topside box was on(the middle one sometimes blink). What might be the cause ?
Thanks
Golden


#2

Did you happen to notice how busy the BBB cpu was? That is the number in the lower right of the cockpit.

The other number of interest in the connection latency which is the graph in the lower left, that should stay below 600ms.


#3

i found that the BBB cpu number is 100% ! Gosh, what should i do then…:sweat:


#4

There are three likely possibilities:

  • If running with a 2.8 ROV, the custom USB cable that connects the BBB to the camera is defective. When this occurred in the past we were able to see odd error messages in the logs of the ROV. If you can see messages similar to #musb_host_rx 1654: RX13 dma busy, csr 2020 in your /var/log/syslog file then it is most likely the USB cable.
  • The camera is fighting with a high contrast lighting situation, such as when sunlight reflects light patterns on the side of a pool that also has black tiles on it. If the problem goes away when the lighting changes or when used in other environments, that could be the issue.
  • There is a rouge runaway process on the beaglebone. If you login to the BBB when this is happening, you should be able to use the top command to see what process is eating up the CPU.

#5

Unfortunately, the issue happened again. This time, the number of the CPU is 30 %, it seems that the process of the BBB is OK then.


#6

Hi there, I am having the same problem with my 2.7 ROV with a 2.8 controller board. A week ago, everything was working fine. Yesterday, completely dry, the video froze and when I rebooted the ROV, the video feed was dead. I can use the webcam on my computer so I know it and its USB cable are working. All other processes work, the video feed on the dashboard is just black. Refreshing the browser does not help. I have updated the software and firmware, adjusted the batteries, and restarted a dozen times. I even remade the connections to the topside adapter.
At this point I have to assume it is the USB port on the BBB that is defective–even though it is a brand new BBB. I am out of ideas. Any help or advice would be greatly appreciated.
Thank you!


#7

I am seeing some people have found the webcam works fine on their computer but is not working with the ROV. I want to crack open the back of the camera and check the connections, but I am a total newcomer to wiring and electronics, so any advice would be great! Can I configure a setup for my 2.7 that is similar to the 2.8? Where the USB connects directly into the camera board? How can I go about doing this?
Thanks so much for any help!


#8

For a test, what happens if you have the ROV fired up and you place you finger over the lens? I have seen an issue where the Genius camera fails to send through video in certain lighted scenes. My theory is that it is simply trying to send over too much data. Cutting down the size of the data being sent seems to work around the issue. The screen will be blank… you put your finger over the lens… and then video starts. It then freezes if you expose too much of the lens. If this happens, you can simply reduce the resolution of the camera shot and things should work fine after that.