Vertical thruster running full speed


#1

At my fisrt startup after reprogramming the ESC and trying to calibrate them to....vertical thruster is running full speed!

It doesn't matter which esc I turn on, vertical go full speed anyway...

What is wrong?


#2

Hi Tom

You really have to double & tripple check the programming of the Esc using the program switch on the esc. Do this with the other two esc's turned off.

But first can you tell me if the motor goes into high speed if the 3pin connector on the vertical ESC is disconnected from the Control Board. If it does not spin but does once it is connected then try plugging the Vertical ESC into either the port or starboard connector on the control board. Does it spin when you do this and if you plug the Port or starboard ESC into the Vertical connector on the control board do they spin. If everthing points to the Vertical connector on the control board then you must make sure that the ESC's are calibrated from the cockpit. Do this making sure that the other two esc's are turned off as you program each one.

Please let me know how your testing goes.


#3

thanks for quick respond.
Yes, I will try this.

What is strange is that if I only turn the port ESC on, the vertical starts, if I only turn the starboard on, the vertical starts....I would understand it if the was starting for full speed when I turned the vertical on....


#4

Hi David.
I had the same problem as Tom.
Following your advice I managed to solve it.

Thanks a lot.


#5

I have now tried everything... actually I have done the calibration procedure maaany times now...I'm quite sure it is a calibration issue... I managed to get it up and running ONE time :)...but I found out the port moter turned abit slower then the starboard...so I tried calibrating once more and now everything is f'''ed up again....

My thought is....can it be that the laptop is to old and weak?

How strong should the pc be to manage everything?....Even the video is lagging...

And one more thing...can it be that calibrating with keyboard isn't accurated enough...it seems like the idle zone always comes out of centre.....the motors are running when faders are in senter, but if I slide them abit aside...then they stop

Status now is that the port idle at 0.14 and doesn't have full throttle to the right
The starboard is only full left of right... no increasing or decreasing....


#6

UPDATE:

I managed to solve the problem.

I had to take of the 3-pin connectors and only leave in the mainboard the one I would calibrate. It wasn't enough just switching them of with the switch. They had to be signal disconnected I guess.

I had to put the port in the J-pin for the starboard and visa verse for the port, calibrated and switched them in right alignment....after that forward and backwards and turning ok.
Then there was a issue with the vertical again... it turned out that it had gone back to default settings and I had to program it again....no everything is ok :)

but video lagging a lot and network speed is from 200ms and up.....I guess I need a bigger laptop ;)


#7

Try changing he Video to SVGA on the config.js file you can also put your system into Safe mode with networking to make sure all unneeded apps don't get loaded taking up memory and processor resources.

Video Freezing:
Link to change Video to SVGA
https://github.com/OpenROV/openrov-software/commit/cc27cdb142009905d46fd9fceb7159e4aa763b7f
opt/openrov/src/lib/config.js
@@ -24,7 +24,7 @@ module.exports = {
sample_freq: (process.env.SAMPLE_FREQ && parseInt(process.env.SAMPLE_FREQ)) || 20, //Hz
dead_zone: process.env.DEAD_ZONE && parseInt(process.env.DEAD_ZONE) || 10,
video_frame_rate: process.env.VIDEO_FRAME_RATE && parseInt(process.env.VIDEO_FRAME_RATE) || 15,
- video_resolution: process.env.VIDEO_RESOLUTION || 'SVGA',
+ video_resolution: process.env.VIDEO_RESOLUTION || '1920x1080',
video_device: process.env.VIDEO_DEVICE || '/dev/video0',
video_port: process.env.VIDEO_PORT || 8090,
port: process.env.PORT || 8080,


#8

ok...Im no good in programming.

How do I actually do this?


#9

you can use your browser and go to:

192.168.254.1:3131

this will open cloud9 GUI

then open file config.js :opt/openrov/src/lib/config.js

Look for

- video_resolution: process.env.VIDEO_RESOLUTION || '1920x1080',

and change it to the following:

- video_resolution: process.env.VIDEO_RESOLUTION || 'SVGA',

Then you may need to restart

You may also want to reduce the resolution of your laptop monitor to make it show up larger on your display.


#10

Thanks alot :slight_smile: