V1.5.1 Trident update is stuck at Idle (100%)


#1

Hi all,

I tried to update my Trident for that sweet sweet 1080p video, but things have appeared to stall during the update process. My Android app is up to date, and now I’m attempting to update the robot. The Trident has 3/4 charge, and the update has appeared to finish downloading. Then it gets stuck on Idle at 100% for about 5 minutes or so, before it kicks back into downloading and redownloads the update bundle. It has now repeated this process 4 times. I take it that this repeated download is not normal, as I would expect the app to give me some indicator (Downloading 1/4…) if this was intended. Screenshots below of the idle states:

. Any tips or tricks for getting out of this update circle?

Thanks!
~ Ian


#2

So, after I posted this, I figured I’d

  1. abort the download,
  2. close the app,
  3. re-launch the app, and
  4. try the update again.

This time I had no update loop issues, and it successfully updated on the first go:


I hope this is helpful anyone in the community running into this issue or the dev team. Now, I’m good to go - time to explore!

~ Ian


#3

Thanks, Ian. However, mine is still stuck in loop. I also can’t connect to two WiFi networks at the same time making the download process impossible. The progress bar says 100% for both but never completes and just restarts. Can anyone from support offer a suggestion to remedy this? The download and install need to be separate processes for this to work correctly as far as I can tell. Or else the support for devices is limited. I am on Pixel2 phone, but I can’t use my mobile data for one operation and wifi for the other-- I have to choose between wifi or mobile.


#4

I am also having the update loop issue. Tried two tablets and a phone… The app says downloading gets to 100%, and then pauses for a min or so then says idle 100% for about 5-10 seconds then restarts the download.

Thanks for any help


#5

Hey everyone.

I think we may be able to help out. If you are experiencing this problem follow these steps:
(1) Make sure you have the latest OpenROV Cockpit App.
-connect your device to the internet, head to Google Play, find the OpenROV App page and update should be available if there’s one
(2) Once you’ve got the latest app, connect your device to your Trident WiFi (make sure your batteries are full on both the device and Trident) and open the app as usual.
(3) Head to the “Maintenance” screen and check for update in the top left. You may have done this before but try it again anyway as we are constantly working with our service provider to fix things as they come up.
(4) Give it some time…maybe as much as 60 minutes. If you notice that things aren’t seeming to change on the update screen, try closing (not just minimizing) the app and reopening the app and checking for updates again.

If you get through all these steps and are still hung up that means we gotta get in there and fix it remotely. Send an email to support@openrov.com and let them know you’ve tried these steps already. Give them the following information:

  1. Your Trident serial number on the bottom of Trident
  2. When you are typically available for a phone call / skype call
  3. Phone number / skype name depending on preference

Most of the time we can fix it pretty quickly and once it updates past this spot it should update from then on just fine.

Thanks in advance and reply here if you have any questions.