Using OpenRov software with the raspberry Pi


#21

@andreas_lindberg

Yes, the Trident will be running the same cockpit software. There will be changes in configuration and capabilities, since the hardware has changed a bit (handled with a platform abstraction layer in the code), but the code powering the logic and functions is the same. We have the intention of keeping it that way as well.

So far, I did an initial port in a very manual manner, taking a base DietPi image and manually customizing and installing all of the software/dependencies and writing modified scripts for firmware build/upload and whatnot. I’m currently working on the platform abstraction layer and reworking how we handle functions like building and uploading firmware, communicate with the MCU, etc. such that there is a standard path for getting the OpenROV software running on any computer module (will make it much easier for people to extend on and make images for other boards besides the Pi).

The initial go at this infrastructure should be ready for consumption soon. I’ll be sure to let people know when there is a relevant set of dev images available.


#22

That’s great Charles. Thanks for the speedy reply.
Would there be any point in getting a pi3 and installing your port (when it’s available) before the Trident is delivered?
I mean, could I (without too much trouble) connect it to say an arduino and control some motors/get a videofeed from it or would this be difficult (I’m just starting out with arduino and have no previous electrical engineering knowledge).

Regards

Andreas


#23

Yes, that would be good and should work. Originally, I started this port on the Rpi2B+, but now we have it working on RPi3s. There isn’t much difference between the two in terms of the image, but the Pi3 will give you the additional Wifi feature. We have to disable the bluetooth capability to reclaim the UART port on the 3 though, so you wouldn’t be able to use that. All of the video, motor control, etc functionality should still work, so it should be pretty easy and painfree to upgrade your existing kit with a RPI3. The only thing we haven’t worked out yet is the best way to mate and fit the RPI to the 2.x series controllerboard, but we have a semi-working solution. There might be an adapter board we can create/sell or you can rig the wiring yourself, but we’ll provide details on how to do that once we get there.


#24

Hi, i’m trying OpenROV to Pi3.
Could you download the completed version img?


#25

Hi Charles!
Is the Pi version scrapped or just put on hold until the iOS version is done?


#26

Hi @andreas_lindberg ,

Right now, all software work on the OpenROV 2-series has been put on hold, as we are focusing all of our effort on Trident. An OpenROV with an improved hardware and software stack is something that many of us internally would still like to see, but it is unclear when or if we will be able to make such an endeavour. If there is any change regarding this, we will be sure to make an announcement.


#27

I was talking about a Pi version of Trident cockpit… Not 2-series.
I’m in the process of testing the Trident cockpit on Pi right now.
I had an SD card that was too slow though and bought a faster one but after installing the OS (Emteria) on the new SD card I can no longer download the beta cockpit app… It says I’ve already downloaded it (which I did to the old SD card) and won’t let me download again. Can you assist?


#28

Sorry for the confusion, it’s just that the topic of this thread was porting the 2.X software to run on a RPi3 instead of a Beaglebone.

As far as running the Trident app on a Raspberry Pi, I have never tried doing this (never tried to run Android on a RPI either). There’s no reason it shouldn’t work though.

What is telling you that the app has already been downloaded, Google Play? I’ve seen that sort of thing happen before when I tried to install an app through the Google Play Web Interface, rather than the Google Play app.

Maybe try the steps listed in this post, but no guarantees:
https://productforums.google.com/forum/#!topic/play/yMmF8Kf9PMM


#29

Thanks Charles, downloading through the play app instead of the web interface worked. Can’t believe I didn’t try it before…

So I’ve got the app running on my Raspberry Pi and I’m able to control the Trident… Motors and lights and such. The heading arrow works too. The bluetooth connection to my game controller works fine. I can see all the HUD information on the screen but there is no video feed. It’s all black.

Trident_Pi


#30

Could be a good (and cheap) option for the people who were a bit miffed that a PC version of the app wasn’t released right away (if one can get the video feed to work).
From what I can tell the Pi is outputting 1280x720.


#31

Sorry, I just realized I keep posting in the wrong thread… Maybe one could move this to a more appropriate place.


#32

Can’t really figure out how to easily move all of the posts, so no big deal.

Couple of ways to try and debug this. These steps are a little technical and require having the Android tools installed. I can elaborate more if needed.

  1. adb or ssh into the RPI and run “tcpdump -i <whatever interface you’re connected on> -w test.cap” while in the Pilot Screen. Let this run for 5-10 seconds and then stop it with ctrl+c. Use “adb pull” or “scp” to download it off of the RPI. You can send this to me to analyze to see if the video traffic is coming through at all.
  2. Download Android Studio and connect to the RPI over USB (need to turn on developer options and enable USB debug). Then open the logcat tab, target the RPI device and see if there are any errors relating to H264 decoding.

#33

Alternatively, try using the recording button to record a short segment of video (usually the top button on the gamepad, triangle on playstation controllers). Leave pilot mode and go to past dives. If it shows up, then video was being received, it just couldn’t be decoded. If it doesn’t show up, it’s probably not coming through at all over the network.


#34

One more option going the ADB route to make it easy:

If you have adb available, even without the full Android Studio, you can enter pilot mode and run:

Android/Sdk/platform-tools/adb logcat > cockpit.log

You can e-mail me the cockpit.log for further debugging.


#35

Thanks for your suggestions Charles!

Some might be a bit over my head but I’ll give it a go and report back. Might not be until the weekend though.


#36

@charlesdc This is picking up where you and @andreas_lindberg left off. I was able to get some adb logcat data that I sent to your email @openrov.com as a GDrive link.

If I used the wrong email, I’ll send it through support, or let me know the right one.

Thanks