Using IMU/Depth Sensor with Alamode


#1

Hi,

I just got my IMU/Depthsensor to work with Arduino Uno. After some help from the other members (switching to secondary address for IMU did the trick).

For my project, I am using a raspberry pi with alamode (arduino shield). When I tried the same sketch here, I get the pressure and temperature values without any hassle. I run into some errors with the IMU initialization again. I get the error:

Product ID read as 0 indicates device is either incompatible or an MPU3050

mpu_init failed with code: -6

Anyway I can solve this?


#2

Hey Prasanna,

Having not tried it on a raspberry myself, and since it appears it works on the Uno, I would suggest double checking the timing of the I2C bus. It may be that our pressure sensor auto switches between 400Mhz and a faster/slower I2c bus automatically, but that the IMU is less forgiving.

-Brian


#3

Hi Brian,

Thanks for your response.

I tried connecting the alamode to my computer using ftdi and imu to the i2c pins in alamode without connecting the raspberry pi at all. I still get the same error. Alamode is supposed to behave like arduino uno, so I have no idea what's happening.

For now, I have decided to ditch the alomode and stick with the arduino.

Thanks anyway.