Updating software on vanilla 2.5.1 image


#1

I just upgraded my 2.6 ROV to the vanilla 2.5.1 image due to software problems. Now I’m trying to upgrade 2.5.1 due to other problems (CommandBufferOverrun, I can open another thread). On FInal Errants I read that the update is not working. It’s certainly not working for me:

  • the “Update package list” spinner spins indefinitely
  • list of branches remains empty
  • error below list of branches:
    {"data":"","status":0,"config":{"method":"GET","transformRequest":[null],"transformResponse":[null],"url":"plugin/software/branches","headers":{"Accept":"application/json, text/plain, */*"}},"statusText":""}
  • openrov.dashboard.err.log is empty. Latest from openrov.dashboard.log: GET /plugin/software/branches [32m- [0m- ms - -[0m
    I tried poking around the code, but seems like the update code changed quite a bit since then, so I’d like to just update it.

What’s the best method to update the software on 2.5.1?

Some things I tried:

  1. /opt/openrov/cockpit/update.sh is no longer there.

  2. sudo apt-get update
    sudo apt-get install openrov-rov-suite
    After me overcoming the proxy the package still can’t be found.

  3. I git cloned the latest openrov-dashboard directly to the ROV, but after replacing in turned out I need forever-monitor node package.
    npm install forever-monitor gets stuck on
    npm http GET https://registry.npmjs.org/forever-monitor
    I can send error log if relevant.

Details of the proxy problems:
I am sharing internet with ROV from my Mac: WiFi->USB. It works well only if I clear the proxy settings everywhere, that is set http[s]_proxy and HTTP[S]_PROXY to empty.

Sorftware version list:
openrov-arduino-firmware - 1.0.1-48-g2f3c8a8-master openrov-avrdude - 6.0.1-4 openrov-cloud9 - 0.7.0-4 openrov-cockpit - 2.5.1-90.4fa5ce openrov-dashboard - 2.5.1-47.9f498c openrov-dtc - 1.4-4 openrov-ino - 0.3.6-9 openrov-mjpeg-streamer - 2.0-6 openrov-proxy - 0.1-20 openrov-samba-config - 0.1-5


#2

I just tried the update function on the brand new 2.7 ROV, also 2.5.1 software and getting the same error - unable to get list of branches. Some follow-up questions:

  • What network setup is the standard for ROV to be able to connect to internet (see my proxy issues above)?
  • Should any of the workarounds I proposed just work?
  • What’s the simplest setup people use for updating to stable?
  • What’s the dev setup? Is editing code on the ROV common or do you guys clone a git repository from your laptop/desktop?

I’d be grateful for help!