Updated, now having difficulty connecting camera - have to 'reload arduino from card' then restart chrome


#1

Quick question from my sea trials #3

Updated to the newest (5) last night and now the zero depth/calibrate compass doesn't work as a rescue for when the camera doesn't come on after startup (like it did for previous version).

The startup with camera working is intermittent, i thought maybe it was voltage but doesn't seem to make any difference with freshly charged batteries.

When I was dragging driftwood around accidentally with my tether today I had a voltage drop enough to freeze things up. I tried a restart from chrome, after a bit cockpit started back up but again without the camera. I tried the Zero depth, calibrate compass, zero depth thing to no avail. I ended up selecting 'reload from card' and then restarting chrome and got camera to connect.

Disclaimer, i did try the new 'update software' thing, and had three items that installed successfully, but it almost looked like one of those items was 'older' than the new update from github?

I may give reloading from actual card and flashing things a try and see if that helps?

I've taken out any odd connectors and have run the home port direct to the tether (I had a little white connector in there and thought maybe it was causing too much resistance) with no change.

Startup with the update seems to take a long time compared to before, but the light flash to indicate 'ready' is a nice touch.

On the bright side, my dive buddy with a pro camera system came out today and shot some STUNNING footage of the OpenROV in the water, I'll be editing that tonight :)

Thoughts on my camera issue? Thanks!


#2

I flashed the beagle bone with card and things seem to have sorted out, have camera back etc. All the "updates" showed up again on the cockpit but i opted to not install any of them to see if that helps. It also wiped simple-theme plugin but at least i have my camera back.


#3

Hello,

In the new version of the software the "zero depth" button actually zeros the depth reading.

If the camera does not load you can restart cockpit which will also restart the video process. This can be done by logging into Dashboard (192.168.254.1) and then clicking "stop" under cockpit and then wait a few seconds and then clicking "start." Give the ROV about 30-60 seconds to boot up cockpit and then when you go to cockpit (192.168.254.1:8080) the video should be working.

I hope this helps and I am excited to see the video footage!

-Brian Grau


#4

right now it seems reasonably stable with no extra plugins and no special updates (meaning via the new updater process) Flashing the beagle bone seemed to clear up whatever was going on so far. Although I like the look of the simple-theme and the updater seems super cool, I'll wait a bit to try it again, it took way too long to get things sorted on the beach last time and my dive buddy was waiting floating around in the water getting cold. Here is video from the day :)

https://vimeo.com/111490156


#5

Very nice video, thanks for sharing!


#6

Problem is persisting… I had great chat with support staff and we tried a number of things… Right now to get the camera to turn on I need to put a disk image on so card in the beagle one. Today’s sea trials were short but did get a good feel for how many corkies are needed and how far apart :slight_smile: