"Unsupported software" after update to new software on BBB


#1

Have a 2.6 ROV and just tried to install the v2.5.1 ROV FLASH image to update the BBB.
Everything ran fine up to and including the update to Arduino. But then after restarting the ROV I dont have any connectivity (no video, no controls).
And only this message on the display:

Unsupported software product rev 5
mpu_init failed with code -6
log Failed to init on both addresses
Depth Sensor initialized I2C

Have tried restarting / reinstalling but nothing seems to work, Any ideas?


#2

Double check that you have fresh batteries.


#3

just fully charged them


#4

I assume you are using the 2.5.1-final build? Since restating did not help, try eliminating possible corruption during the firmware update by re-uploading it from the settings menu.


#5

Thanks for your help.
Just tried to re-upload from the settings menu but still the same.
Going to burn the image to the SD card again and start the process again.
Any ideas what could be wrong? ROV was working fine until I tried to update it.
Had it in the water last week


#6

Nope. Still the same
mpu_init failed with code -4
log Failed to init on both addresses
Unsupported software product rev 4
Depth Sensor initialized I2C

Also this new message
og Watchdog was triggered and the following was read from EEPROProduct ID read as 0 indicates device is either incompatible or an MPU3050

I have no idea what any of this means. Any ideas?


#7

Hi Stu:

The error messages you're seeing in the log seem to relate to the IMU chip (Invensense MPU-9150) that is used in the IMU/Depth Sensor accessory.  I assume you have one attached since the Depth Sensor appears to be initializing.

Back in the early days of the 2.6 production run, we had a bad lot of IMU boards, that would sometimes get stuck on the message about “Failed to init on both addresses”. I think some software changes were made to cover this. It’s puzzling why this would pop up now.

Can you tell us what build you were upgrading from? That might give Brian some clues. Also, did you pot your IMU board with clear epoxy? There is a small silkscreen difference on the bad run of IMUs, and you might be able to see if yours is one of them. Though why it would wait until now to act up, I have no idea.

-W


#8

Hi Walt.

Thats interesting.
I’m not sure what build I was upgrading from. It was whatever was on there from when it was delivered. Like I said, its a 2.6.
(Sorry, Im a marine biologist and a bit out of my depth when it comes to the software - am mostly getting by due to some of the great tutorials!).

I did pot the IMU board with clear epoxy.What exactly do I need to look for?
If I disconnect the IMU from the DB-25 connector and upgrade would that help? (a working ROV with no depth sensor is better than nothing)

Stu


#9

Hi Stu:

Unfortunately the wires on the DB-25 connector are for the whole I2C bus, to which both the IMU and the depth gauge are connected. So you can’t clip one without clipping the other.

I’ve attached the artwork for the correct IMU board. Note that there’s a small triangle near the wire pad marked 3.3V. If your board does not have this, it’s one of the ones in the defective lot. I don’t know whether getting a replacement board would help, but it might be worth a try if Brian can’t figure anything else out.

If you want to go down that route, I’d drop tech support a line and reference this forum thread.

-WOpenROV_Depth IMU_check-plot_10-22-13.pdf (17.8 KB)


#10

Hi Walt.
It has the triangle.

But a thought occurred. When I first started to try to update the other day and was moving things around, one of the I2C wires popped off the DB-25. I re-soldered it but didnt check connectivity. Perhaps there’s a bad connection there? I can check the connectivity, but would rather explorer other options first rather than starting removing glue and heat shrinks. But I guess thats the best option.

I asked about removing the depth sensor from the DB-25 cos presumably I could have a ROV without a depth sensor? Its an accessory right? I could have a ROV without a depth sensor.


#11

Hi Stu:

Whoops. I had misread your previous comment.

Yes, you can just remove the 4 I2C wires at the DB-25 connector (3.3V, GND, SDA, SCL), and you will lose the depth sensor and the IMU. But the rest of the ROV should function.

I’m hoping that Brian will be able to weigh in with some ideas before you go unsoldering wires, though.

-W


#12

Ok. Am not going to do it now.
Thanks again for your help


#13

From what I can make of the symptoms, it really feels like something is off with the wiring or the unit itself has gone belly up. You can to the the AConfig.h file and turn off the IMU first, and if still having problems, the depth sensor in configuration.

http://openrov.dozuki.com/Guide/How+to+assemble+the+IMU-Depth+Sensor+Module/4 has instructions.


#14

Thanks Brian.
I’m working away from home at the moment, but as soon as I get back will give that a try.
When I ssh in to the rov what is the command to turn off the IMU? I just change it back to 0?
Cheers. Will let you know what happens


#15

Hi Brian,

I’ve turned off the IMU/depth sensor, and updated again from the SD card
but still getting an error message.
This time:
mpu_init failed with code -6
log pilot setup complete
Depth Sensor initialized I2C

lasers on, no camera.no motors
Any ideas?


#16

to update:
so… this is embarrassing… Checked the resistance on the wires from the depth sensor to the DB-25… and there was a short. A bit of solder was shorting two of the wires as they entered the DB25. All cleaned up and just turned it on - full connectivity.
Will update again to make sure it completed properly…
Thanks again for your help


#17

so, just to close this off.
Nothing I did worked.
I resoldered the wire I mentioned above. It wasnt that.
I downloaded the software again to the SD card and tried again. No. Both flashing the software and from the card.
This continued until the new software update came out which I am running from the SD card - all seems to be working well now!