Unable to finish Trident firmware update


#1

Trident has downloaded the latest firmware update, and is now prompting to apply it before anything else can be done. When I say ‘ok’, the “Checking the ROV’s Internet Connection” page comes up and stays there. I can see on the wifi router that the trident is connected and has an IP address. I have restarted everything several times and also tried it with the phone in airplane mode with just WiFi enabled. I have also tried a second phone. No joy.

Help would be appreciated as the Trident is just a brick now.

Thanks,
Peter


#2

I had the same problem, but then I tried to make sure that the Trident battery and the Tablet battery was fully charged. Then I pressed on the small square down in the corner of the window to the left in the Cockpit app, where it says “Searching for Trident” and “Pilot” up in the corner. If you see the small icon in that lower right corner, press it and see if that works better!

/Peter


#3

Thanks Peter - Yes, I’ve tried that. Freshly charged Trident and phone, clicking on the little ‘update’ icon specifically and still nothing.

Highly frustrating!

Cheers,
Peter


#4

I know :frowning: Then send an email to support@openrov.com and hopefully Nicole or Zack can help you with it!

/Peter


#5

Same situation here Peter. Very disappointing, as I was supposed to be taking it to the Arctic tomorrow :frowning:

Simon.


#6

Hi all,

Apologies for the frustrating situation. This problem is one of the major issues that has been resolved in the new version of the app that we are about to publish. We are doing the final testing for this release now, which is going well.

In the mean time, I would like to offer a potential workaround for those of you experiencing the issue:

The underlying cause of this issue is that the app is not properly displaying the feedback that the vehicle is sending it about the firmware upgrade. When you see the “Checking the ROV’s Internet Connection” screen, it is very likely that the vehicle actually IS performing the upgrade underneath the hood, it’s just that the app isn’t properly showing that. One thing that you can try to do is this:

  • Hit ok to start the firmware upgrade
  • When it gets to the “Checking the ROV’s Internet Connection” page, just let it sit there for 5 minutes
  • After 5 minutes, hit the back button on the phone/tablet to go back to the dashboard
  • Force close the app and re-open it
  • At this point, the firmware upgrade may have successfully gone through and the indicator might be gone.

It’s kind of a guessing game, since there is no feedback, so you may have to try a couple of times.

If this doesn’t work for you, please just hang tight, the new release will be available soon!


#7

Same problem here. Major issue for me as need Trident working for a teaching field project next week. :frowning:

On the release of the new app. Do you have a time for its release??

Am trying the possible fix in charlesdc’s post here.

Started the app with tablet connected to Tridents wifi. Then, while on the “checking ROVs internet connection” page, went to settings on the tablet and changes wifi to my lab connection so it can see the internet. Am letting that run for 40 mins or so at the moment and will report back.


#8

@i.mckernan

We are planning to do a limited release tomorrow evening and if the weekend goes well, a full public release (promoted out of Beta and onto the Google Play Store) on Monday, fingers crossed.

If anyone has a critical need to have their vehicle updated today or tomorrow before we put this release out, please contact support@openrov.com, as we can likely perform a remote fix on your unit over the internet.


#9

Tried the potential fix upthread. No joy.

Am in touch with zack on this. I know this is an issue but given all that, am appreciating the support guys. :slight_smile:


#10

REport on the wonderful support dudes. :slight_smile:

That which thou did has worked.

Am now good to go.


#11

Thank you for the insight on this Charles. I am having the same problem as others and am hoping I can get the Trident working this weekend.

The only way I have been able to successfully connect and control the Trident at this point is to open the cockpit app while connected to the internet and login to my account. I can then control remotely.

One piece of this upgrade that I’m confused by is how the Trident is getting online in the first place? Does it connect directly from it’s wifi topside unit to my internet router or does it go from the topside to my tablet and then online? I was also thinking that I should be using my phone to do the upgrade so I could connect to the Trident via wifi and then still have mobile data to get online.

Thank you


#12

Hi all,

The new version of the app is live now: 1.4.1. There will be an e-mail going out later with more details, but you should be able to update now!

@balder.matt

Hopefully the following image will help to clear things up:

To pilot Trident, you only need to connect your Android device to the Topside’s WiFi Access Point. This will have a network SSID called “Trident-WXYZ”, where the WXYZ are the four randomly generated numbers.

To download updates for your Trident, you will use the app to command Trident (which has it’s own WiFi chip inside of it) to connect to a different WiFi AP that will be providing internet to the vehicle, such as your home, office, or hotel WiFi router.

Cellular/mobile data is generally not involved in this process, only WiFi.

Feel free to let me know if you have any more questions.


#13

Mine just says ‘Checking the ROV’s internet connection…’ and nothing seems to happen. Tried it for about 30 minutes and still no good.


#14

@dronetech00

That message is only shown in the 1.3.3 release. Please try updating to the latest app release, which should resolve your issues (1.4.1). The app can be updated by logging into the Google Play Store with your e-mail that you provided to support.

We will be releasing the app onto the public google play store shortly, which will mark the retirement of the Beta group, so anyone with a Google account can download and install the app without having to be added to the “beta list” by support.


#15

I see thanks all sorted and working properly now.


#16

Thanks guys, my app updated without issues as soon as I logged in and selected update in the Google Play Store.

The app then updated Trident as soon as my Samsung Galaxy Tab S2 connected to the topside unit and I selected “Check for updates” from the “Maintenance” section. I needed to enter my wifi password to allow Trident to connect to the internet.

There were a couple of slight pauses and the app showed “Update state: DISCONNECTED” for a moment before showing “Update state: Starting installation of release 2752cc” and then “Update state: Downloading (n%)” where n increased from 1 to 100. Before I knew it I had a “Update state: Update installed!” and then a “All systems GO. You are ready to dive!” message.

The whole process took about 15min.


#17

When will it be possible to take picture in app - like without recording?
Or is this function here now?


#18

Hello Charles,

I was wondering if the latest version of the Cockpit App does not have the ability to adjust controller stick sensitivity? I seem to remember a “developer options” area that had to be made active before adjusting sensitivity for the 3 different power levels.

Thank you,

Matt


#19

@balder.matt

I just checked the latest version and they are still there, but I found that they are still unlocked with the “developer mode” options. They were supposed to be moved to the “Experimental Mode”, which you can unlock by going to Settings, then tapping “SETTINGS” in the menu title 10 times very fast. Once you unlock the Experimental Options, go into that submenu and click “Developer Mode”. The password for this mode is “OpenAdventure”. After unlocking developer mode, go to the “Controls Menu” and the power level adjustments will be at the very bottom.

Sorry for the confusion. I’ll make sure that the power level options get added to the proper menu without so much hidden-option-menu fuss in the next release.

Also, I strongly advise against modifying any of the settings in the Developer Options menu. Changing anything in here will either do nothing or adversely affect your system, as they are designed for specific tests we are doing in-house.

The “Experiments” menu is ok to use, but be aware that the two options in there are not officially supported (1080p and telemetry recording).


#20

Will there also be a button for taking photos? It would be pretty nice to have and should be a “standard” feature…