Two for Two. Replaced Beagleboard with new and then stops working


#1

We assembled the OpenROV 2.8 and followed instructions carefully. Even built the bot in an ESD protected room for the electronics sake. So to help me quickly I am posting here for any other occurrences. We could not get the Beagleboard to connect. After closer examination found that it was not powering up - even when removed from the ROV and powered through the adapter jack. So got an RMA and sent it back pronto. However, I purchased another Beagleboard and had it shipped overnight, flashed the memory, and tested on the bench - not in the ROV. power light came on - it was happy. Placed it into the ROV and the original issue from the other Beagleboard is there again. We lost this Beagleboard. Is there known issue with power off of the OpenROV controller board that might be causing this? I searched the forum, but did not see anything off hand with my search inquiries. When the replacement board from OpenROV comes, I will not put it in there right away until I test out the main controller definitely.

Just frustrated in spending a lot of extra money to get the other Beagleboard just to have it killed too, but happy to know it probably isn’t the issue now.


#2

I saw that you have reached out to our support team with regard to your issue and replacing your BeagleBone Black.

The only time I have seen a controller board kill a BeagleBone Black is if it is installed backwards. This will fry the BeagleBone and it will not power on anymore.

Just to rule this out, the ethernet adapter on the BeagleBone should be on the opposite side of the DB-25 on the Controller Board.


#3

I had a similar issue during a version 2.6 build, with a replacement BBB fail. The BBB’s were never installed backwards or anything like that. After methodically ruling EVERYTHING else out, we ended up replacing the controllerboard. It should be added that OpenROV support staff were awesome in troubleshooting and finding the solution.
Good Luck!


#4

Thank you to both of you for the responses. I tried another one with success to connect with the latest software. Then the replacement came and it too works. Now i have another problem which I need to resolve before moving forward. It is happening to both the replacement BB and my own purchased BB - no video. So off to the forum to research potential issues. Need to rule out camera first…


#5

You can plug the camera directly into a USB port on your computer in order to test it.

If the camera does not seem to be starting you can go to the dashboard (192.168.254.1 or openrov.local) and click on “stop” under Cockpit, wait a few seconds, and then press start.


#6

Thank you Brian. Yes we did plug it into our computer and while it would recognize it, it was finicky about the connection. Purchased another camera - same make and model - and tried it also. It worked in both the ROV and the computer. So, decided to troubleshoot the original camera further and found that the supplied white camera cable for the Beagleboard to the camera was bad. The ground wire (black) at the five pin connector to the back of the camera was crimped too hard and broke the wire. it was making connection end to end on the computer but not the ROV due to the difference in the wiring stress. I removed the all of the pins from the connector, grabbed another USB cable, cut it down to size and then soldered the connectors onto the ends. We are big on soldering our connections due to the inherent risks of crimping and wire damage like we found. Put it back into the ROV and we now are live with video. Thank you all for the help. a few more steps and we are ready for our maiden voyage .


#7

I am glad you were able to troubleshoot this and find where the issue was. I appreciate the detailed explanation of your process for future reference. I am sorry to hear about the short USB cable not working and I will look into the process these are made to help eliminate these kinds of issues in the future.

Your BBB issue has been resolved with our support team as well correct?