Troubleshooting: No Motor activity

#1

UPDATED

I have just received my Trident, and I can connect to successfully it using my Android phone - I can see video, record video, turn the lights on or off, but I cannot make the motors turn. No position of the (virtual) joysticks produces any result.

Does anyone have any advice on what I can try to get this working? I’d love to be able to drive this thing around!

Thanks,

Ben

UPDATE: This appears to be caused by an incompatibility between the OpenROV Cockpit app and Android 9. Everything works as expected when using an Android 8.1 device.

0 Likes

#2

Hey Ben, what input device are you using on the Android 9 device. An external controller? Touchscree?

Thanks,

0 Likes

#3

It’s a touchscreen. I’m using my phone without any external controller.

There’s an odd doubling of text when using the virtual joysticks too, which I expect is also related to version incompatibilities.

Ben

0 Likes

#4

oh that’s strange…Can you try again after you disable bluetooth and cellular data? Like on airplane mode? Still the same problem?

Z

0 Likes

#5

I did try with both bluetooth and mobile data disabled, and it still didn’t work.

I just now tried it using airplane mode (only with wi-fi enabled, obviously) and that doesn’t solve the issue either.

-B

0 Likes

#6

im having the same issue. any news how to solve this? last time it was used, it was working just fine.

0 Likes

#7

The problem was solved for me by updating to the latest version of the app. Given that so much time has elapsed, I would imagine that you have an updated app by now. I would suggest that you contact support and let them know what is going on. Make sure you have their app version ready, and the Android version that your phone is running.

0 Likes

#8

i have the latest version. i can hear some sound on the motors when i press the buttons but it just wont turn.

…noted on contacting them. will do. thanks for your reply

0 Likes