Troubleshooting my 2.6/2.7


Hi everyone!

I am pretty new to this, and built my OpenROV during the workshop in Oslo in December. It has the frame and motors fron 2.6 and the control board of the 2.7. It has been sitting unused since then and I just got started on it again yesterday. So before I went out I powered it up and everything worked fine - funnily the video feed did not work on my mac in Firefox, but in Safari I got both video feed and controls.

I then took the ROV outside to do a water test, and it would not boot up. I got the first beeps, but not the second - and no feed from the ROV. After a couple of minutes I get flashing main LEDs on the ROV. I noticed then that the middle orange light on the topside adapter was out and pressed the reset button. After that I get all 3 solid lights but still the same result. The first beeps only and after a few minutes flashing LEDs on the ROV. I have checked the cable connections but everything seems fine.

I would appreciate any pointers to help me on the way to getting this thing wet again. The cod are spawning in the Lofoten islands in northern Norway and are eagerly awaiting my OpenROV at 70m depth :smiley:


Hi Kristian,

When I ran into a similar problem it was a filesystem corruption on BeagleBone due to unclean shutdown. You can either reflash or try to fix it by logging in via serial console and running fsck utility manually (but that’s more involved).

Easiest way to do it is to flash a new image to a microSD card and just use that:

It may also be something else entirely but if you’re eager to start the season it may just do that trick.


Have a simular issue on my 2.6 I needed to re-flash it. Be aware that it can stop working at any time so It can be beneficial to bring a backup BBB


It is also possible to fix filesystem errors by connecting to BBB via a serial port but it involves taking BBB out of the tube and connecting to either MicroUSB port or via traditional serial connector and running “fsck” manually in the recovery console. That is what i usually do.

Keep in mind that there is a bug so you have to run fsck in manual mode and delete all the multiply-claimed blocks when prompted.

I believe the filesystem corruption problem has been fixed in recent versions.


If the bealgebone lights are not correct, then yea, probably a corruption of the SD card. You can run through the troubleshooting steps here: Troubleshooting: Cannot connect to ROV