Troubleshooting: Can't connect to cockpit, here's what I've tried so far


#1

Hello Everyone,

While trying to connect the ROV to my laptop I can’t get into the cockpit, it says page cannot be found.

To attempt to connect I followed the directions in the manual.

When I plug the USB into the topside box the ROV turns on and makes a noise and the main lights on the ROV turn on and the lasers start blinking after a while. However I can’t connect to the cockpit using chrome.

I found that all the lights on the topside box are turned off. when I press the reset button on the topside box the power led goes green but turns off again after the button is released.

Additionally, within the ROV there are no amber/green lights around the beaglebone’s ethernet port, and there are also no illuminated blue LED indicator lights, not even the power LED. I checked the voltage input from the control board into the beaglebone and it read 5V as expected. My batteries gave about 12V at the time.

I’ve tried different Ethernet cables and a different computer to no avail.

At this stage I’m wondering if it could be a problem with either the beaglebone, the topside box, both or neither!

I’d really appreciate any input you guys might have.

Thanks for taking the time to read this!


#2

Try and conect your Beaglebone ONLY to your computer directly, using the USB and Ethernet cables. Remember to set your computer to have a static IP address as per step 18 in the dozuki: http://openrov.dozuki.com/Guide/Guide+6+-+Finishing/68.
If the BBB is working, you should get the cockpit up, but obviously without any telemetry or camera.
This is a quick and easy way to check if your BBB is working or not. You can also update the BBB software this way.


#3

Also, the guys at HQ wrote a troubleshooting guide that is a great resource, but I can’t find it. Maybe @Brian_Grau can help?


#4

Hi Roy, thanks your for advice, I will try that first thing tomorrow. If it doesn’t work, then I may need to order a new Beaglebone? How about the Topside Box? if the beaglebone doesn’t work is it correct that no lights are on? or should they be on regardless?

I had a look at that troubleshooting guide earlier, here it is for anyone’s reference.

https://openrov.yonyx.com/y/conversation/?id=7c5b2d70-eac3-11e4-a42b-bc764e1028dd&h=1&st=0


#5

Not sure if it matters, but I’ve had better reliability with my older BBB Rev B vice the Element14 Rev C. I’m trying to hunt down an official Rev C for testing.

I was originally running a Rev B, switch to the Element14, it booted about 3-4 times and then wouldn’t connect again. I switched back to the Rev B and everything works fine. So end of the story, I’m not sure, but I plan to use the official BBB’s from now on.


#6

Here is a link to the interactive troubleshooting guide for connectivity.

This is going to be the first place to start. All three lights on the topside box should be solid on or blinking. Double check that the tether is connected to the topside box fully and that the two boards on the inside of the box are fully seated and all pins are in the headers.

This is also good just to check that the BBB is working properly.


#7

Appreciate your replies,

Just tried this, when I plug the BBB into the computer, there are no lights on and I can’t connect to the IP address… So i’m figuring that it’s bust and I’m going to order a new one now.

Assuming the beaglebone is broken, should I still expect the three lights to be on or blinking? If so I may as well order a new top box while I’m at it.


#8

The Power and Ethernet Lights should be lit up when you have those wires connected to your computer, even without the tether connected.

This unfortunately does sound like the BBB is not turning on anymore. Please contact me through our support system to get this replaced.