Troubleshooting: Cannot connect to ROV


#1

Prerequisites:

  • OpenROV image 2.5.1-final or higher installed

Diagnostics:

  1. When the ROV starts up, does it have blue lights that moves from one side to the other and back in a smooth motion like a Cylon visor? It may take up to 2 minutes for the ROV to complete its startup.

If the answer is “no” click the answer below:

No, then then the software is not starting up properly on the ROV. You can try powering off and on the ROV and trying again. If the problem persists, you may need to reload the software image on the ROV. Regardless of the software loading, the beaglebone should have a blue power on led that is solid on and the amber lights around each side of the RJ45 plug on the beaglebone should be on.
If not, the beaglebone may be having a problem powering on. If that is the case, try removing the beaglebone from the ROV and connecting it directly to the computer using the micro-usb to usb cable. When connected these lights should come on. If they do come on, there may be an issue with the power on the controller board. If they don’t come on, then the beaglebone is probably bad and needs to be replaced.

  1. Disconnect the ethernet plug that connects the beaglebone to the controller board inside the ROV. Connect the ethernet cord from your computer directly to the beaglebone. Are the two amber LED lights on either side of the ethernet port of the beaglebone lit/blinking once everything starts up?

If the answer is “no” click the answer below:

There must be a wiring fault between the ROV and computer. Try replacing the ethernet cable. If that does not work, try another computer. If replacing the cable and the computer did not work, it may be a defective beaglebone.

  1. Double check that your local computer’s ethernet adapter has been set to the 192.168.254.2 or higher address. Open a terminal/command prompt and issue the ping 192.168.254.1 address. Do you get a positive ping response?

If the answer is “no” click the answer below:

No? The physical connectivity is probably okay. There is probably an issue with the configuration on the laptop. If you have internet sharing enabled, turn it off and try again.

  1. Using ssh or putty (windows), can you establish a ssh session with the ROV?

If the answer is “no” click the answer below:

No? If we can ping the ROV but we cannot SSH in to it, something has gone wrong with the image. Download a new version of the image and re-burn it on the ROV.

  1. From the SSH session, execute the following command ps aux | grep cockpit. Do you see a line that indicates the openrov-cockpiit is up and running? (You should see two lines, one for the grep command itself, and one for the running cockpit).

If the answer is “no” click the answer below:

No? The key software for the ROV failed to run. Use the command cat /var/log/openrov.err.log and post the results to the forum to get advice on how to proceed.

  1. Using the browser, go to the url http://192.168.254.1:8080, if you still don’t get the ROV cockpit, publish the results of what you do get to a forum post to get more advice.

Can not connect to ROV
Connecting to Cockpit
Connectivity Issue
Rov offline,
Troubleshooting my 2.6/2.7
ROV Suite 30.0.2 released
Control plug lights not lit
Updated beaglebone image, now problems
New 2.7 build - can't connect to beaglebone
Unable to Connect to OpenROV v2.6 (Connection Timed Out)
Tried updating image, now problems connecting
[solved] Can't connect....need help!
[solved] Trouble connecting to cockpit after software update
#2

How do you reload the software image? I was able connect and uploaded the firmware. I disconnected and now can not re-connect.On blue light (first in from the edge) pulses like a heartbeat, while the third in from the edge pulses like a strobe.

Thanks for the help,

Charlie


[solved] Trouble connecting to cockpit after software update
#3

When I connect the ethernet cable directly to the beaglebone I am able to connect to the cockpit, however when I attempt to connect through the tether and homeplug I am unable to connect, additionally the on ROV ethernet connection never lights up on either side when connected to the onboard connection but does when going straight to the PC. What should my next troubleshooting steps be.

Thanks,

Chan


#4

Looked through some similar threads, reseated the connection from the beaglebone to the other board on the ROV as well as the board that connected to, on power up all was well.


#5

We have been hard at work here at OpenROV in order to help our customers have the most success with their vehicles.

We have put together a self-help connectivity troubleshooting guide in order to handle the most common issues that arise with the units. If you are having problems with your unit we encourage you to use this guide.

If you have feedback for us please let us know.


Troubleshooting connectivity issues
#7

When the ROV starts up, the blue lights 1-4 do the following:
1 on, 2 on, 3 on, 4 on, 1 off, 2 off. 3 off, 4 off, 4 on, 3 on, 2 on, 1 on, 4 off, 3 off, 2 off, 1 off.
Is that still the right kind of motion?
I have looked through this guide and it points to my BBB being faulty. I looked at this guide because my Camera wasn’t working after the software update, however it was working perfectly fine before the update, so how can the BBB be faulty.


#8

Never mind, it is my camera which is faulty, as it worked when I used a different camera.


#9

OK I will try thank you king168!