Trouble connecting with new Dev Img 30.1.0


#1

Hi Brian,

I am using the new developer image. Currently, I can connect to the cockpit through openrov.local:8080, but not through openrov.local/cockpit. I also cannot connect to the dashboard or the cloud based ssh. Cloud 9 and Ungit also work as they should.

I can still ssh in fine using putty.

Thanks,
Vai


New Developer Image ready with 30.1.0
#2

Thanks for the report @omahavaibhav. I was toying with something right before cutting the image that must have aborted the startup of the nginx service. If you ssh on to the rov and start nginx with sudo systemctl start nginx I suspect you will be able to connect with /cockpit.

What O/S are you using?


#3

You are correct, I am able to connect to /cockpit, /wetty, and /dashboard if I manually start nginx.

I am currently using Windows with Putty. I also have a Mac nearby if necessary.


#4

Thanks. Just looking for confirmation that a windows user was able to use the openrov.local names.


#5

Another issue is that I seem to only be able to connect to the ROV when using the static IP 192.168.254.2. Otherwise, I am running into issues connecting.


#6

If you use enable DHCP, can you see what IP address you are assigned? It should be 192.168.254.10+.


#7

If I am reading this correctly, I am assigned 169.254.195.74 when connected to my computer.

Connecting to my router gives the IP of the openrov to be: 192.168.1.134


#8

When connecting using DHCP, be sure to power up the ROV after your computer is connected. Let me know if that is what you did. After the ROV starts it should grant and I address within 60 seconds.


#9

Following your instructions gives me 192.168.254.17. Now I can connect to all of the webpages as expected.

However, when I share my wireless connection with the beaglebone, the IP changes to 192.168.137.1


#10

Thanks for the update. Okay, so in the case that your laptop is going to share its connection. You first enable the internet sharing, make sure the ROV is plugged in, and then start the ROV up. The ROV should pull the DHCP address from your laptop. The address depends on how the laptop internet sharing is configured. On windows, there is a way when sharing your internet connection to see what machines are connected. You should hopefully see the ROV and it should be responding to the openrov.local DNS name.


#11

Followed those steps and I learned that if I turn on network sharing, Windows automatically sets a static IP for the ethernet connection of 192.168.137.1. Solved the problem by setting it back to automatic.

However, I am still having issues connecting to the internet.