Tried updating image, now problems connecting


I have a model 2.8 OpenROV that has been working well for many dives over the past 6 months. I decided to try the newest development image on my ROV, and things got messed up in the process…

First off, I didnt realize that the dev, image was intended to run off of the SD card, so I took the BBB out of my ROV, put the SD card with image into it, powered it with the USB cable, and let it run for an hour while I did something else. Upon removing the card and putting my ROV back together, I was unable to establish a connection through the cockpit. Then I reloaded the 30.0.3 software by flashing onto the BBB–again, unable to open the cockpit. Tried running from the SD card-no cockpit. Rolled back to version 30.0.2-no cockpit.

In all cases, the ROV went through the appropriate starting sequence (in terms of lights and beeps) and eventually began blinking LEDs to indicate no connection with cockpit. The difference in beeps between the two software versions was even evident, which makes me think the software is loading correctly. All the appropriate lights on the topside adapter are on. My batteries are fully charged. Ethernet is set up correctly (as it has always been). I also tried on another computer with identical results.

I went through the diagnostics here: Troubleshooting: Cannot connect to ROV and here: . I was able to successfully ping the ROV, but I could not establish a PUTTY connection. What gives?

If I take the BBB out of the ROV and hook it up to my computer, it recognizes it as a device, but does not show up in Explorer, and cannot access through or Is this normal? I never tried doing this before the problems loading cockpit began…

If you have any idea what’s going on, have any suggestions for further troubleshooting, or any tips for fixing this, please let me know!




Can you access the dashboard? try stopping and restarting the cockpit in the dashboard.


I was able to get it up and running! I re-loaded the image on the BBB using a different micro SD card, and it worked so much better. I was previously using a 16gb PNY brand card, which was giving me trouble. The 8gb PNY SD card worked on the first try.