Trident onboard storage filling up and can't clear it off

I have been noticing the Available space status bar shrinking consistently over my entire ownership of Trident. After deleting all video files off Trident onboard memory (I don’t use the device recording options) my available space does not jump back up towards the 20gb available level but instead decreases slightly. All I can imagine that is happening is that there are some type of log files being stored that are slowly accumulating and decreasing storage capacity. I’m concerned that one day in the future I will have no more memory left on board to use for video recording.

Any insight on this issue would be greatly appreciated!

There’s some log files in /data/openrov/logs/. Mine are only 60 MB total but I’m curious how large yours are if you dive a lot.

After deleting the 1080p videos on the Trident using the Cockpit app, I’ve sometimes seen directories in /data/openrov/video/sessions/* still containing videos. Each directory will contain a recording session with a 0.mp4 video and a couple of metadata files.

What are you using for recording these days?

I took a look for the log files but I’m confused about how they would be accessed. I’m assuming that they are not accessed through the Sofar Trident app and I didn’t see any menu available to access those log files. Were you referring to the files stored on my tablet? I do have files under Android/data/com.openrov.cockpit/files/data and the folder size is around 700mb. I do delete this folder periodically and that can create problems that sometimes leads to me having to reinstall the cockpit app but that’s a separate topic.

I may be interpreting your response incorrectly but it sounds like you are accessing the Trident internal memory in a different method than through the cockpit app, perhaps through local wifi? If you could provide insight as to how you’re doing this I’d greatly appreciate it!

I actually have two Tridents now. One I have had for about 3 years and the other is new. These pictures show the onboard recording time available on both units. Both Tridents currently don’t have any onboard videos stored on them that are viewable in the Past Dives menu in the cockpit app.

Original 3 year old Trident (remaining time shows 01:02:50)

New Trident (remaining time shows 02:08:22)

As for what I’m using for recording these days I guess I don’t fully understand the question. I use an Nvidia Shield K1 tablet for my controller device and record 1080p video using Trident camera and onboard memory.

Thank you

Hi @balder.matt

The files are on the Trident RPi3 memory and you’ll need an SSH client to access them. I use the Android JuiceSSH app but it requires Android v8.0. From googling, the Nvidia Shield K1 seems to have Android v5.1 Lollipop.

On Win10, I use the PuTTY SSH app, but there are more options. Linux and Mac have SSH clients installed by default.

Once you have the SSH client app, you’ll need the topside WiFi AP (TSAP) address from the Cockpit app :
Cockpit app → Maintenance → Network addresses : like 10.1.1.###

In the SSH client app, enter the following in a new connection field :
rov@TSAP-IP
TSAP-IP is something like 10.1.1.### from above
Click to accept all the encryption jargon.
Enter the PW of OpenROV

You should see a prompt from the Trident RPi3. Enter the following after the prompt and send some screenshots.

ls -alsR /data/openrov/logs/
Mine is only around 60 MB.

ls -alsR /data/openrov/video/sessions/
This should be empty if in PAST DIVES you deleted the all the Trident videos.

If the above don’t show GBs being used, I have no idea where the memory is going.

I asked what you’re using for recording because I thought you mentioned the Insta360 One x camera back in 2019.

Hope it helps,
Bill

Thank you for all the detailed information Bill! I will get into it and report back.

I haven’t been using the Insta360 One x camera these days on Trident but thanks for reminding me about that. It is a cool perspective for sure.

Matt

I got the PuTTY SSH app installed but didn’t make it very far on connecting to Trident.

My cockpit maintenance screen:
Network addresses: 10.1.188,192.168.0.133

In PuTTY I entered rov@10.1.1.188 but all I got was a blank prompt screen that didn’t let me enter in anything.


I tried entering rov@10.1.1.188, 192.168.0.133 but I got an error message.


image

I feel like I’m missing something obvious but can’t figure it out.

Thanks for your help on this.

My mistake - PuTTY seems to want a Host Name (or IP address ) so just enter the 10.1.1.188. It should then ask to accept the encryption. Click Yes / Accept.

At the prompts enter UN:PW, ( rov OpenROV ) and your in.

Enter the previous ls commands. What to do next will depend on the directory contents.

Your Host Name is in the prompt. You can also display it with the ‘hostname’ command.

I noticed the 192.168.0.113 IP on the Maintenance screen. I assume this is from your LAN WiFi, but it may change next time unless it’s set to a Static IP in the LAN router. You should be able to use this IP in PuTTY vs the 10.1.1.188.

I’m curious what you find in the log directory.

I made a bit more progress but I’m still not in yet.

I tried changing to other connection types and the only one that seemed to get me anywhere was Rlogin
image

I’m still unclear on what the username is. I tried OpenROV and rov
image

That’s as far as I was able to get. I did review your Video Export Trouble thread posts but I am fairly lost in the specifics of making this connection.

I was curious if perhaps at some point in the future maybe we could schedule a Zoom call and maybe you could help me through this? I would really appreciate it and it definitely doesn’t need to happen soon.

Thank you

@balder.matt In PuTTY you want to check SSH and the port should change to 22.
Connect your laptop WiFi to the TSAP - Trident-####.

From your previous Cockpit → Maintenance screen : ( double check these )
Trident ID: 9f79c5c Also the Host Name PuTTY SSH refers to.
Network addresses :
10.1.1.188 IP to use when connected via TSAP WiFi. Mine is 10.1.1.233.
192.168.0.113 IP to use when the Trident RPi3 connects to your LAN WiFi. This may change on subsequent Trident Power Ons.

Run PuTTY with 10.1.1.188, SSH checked and Clk Open.
Accept the encryption jargon.
login as: Enter rov as the user.
rov@10.1.1.188’s password: Enter OpenROV

In the PuTTY and Terminal screenshots you should see :
10.1.1.188 vs 10.1.1.233
9f79c5c vs 701fe05


You should also be able to use the 192.168.0.* IP in PuTTY if it shows up in Maintenance. Then you can just power on the Trident with an INSULATED button magnet.

$ exit To close the terminal and SSH connection.
You can paste into the terminal from the Win10 clipboard by a right mouse click.

Once you have PuTTY working, you should be able to use Filezilla to copy the Trident 1080p videos to your laptop, just use the SFTP protocol.

Third time’s a charm!

Zoom call? I’ve only used it once! If the above doesn’t work - ok. Just give me a days notice. You’d have to set it up. Also, try using @webhoppery in the post to ping my email. webhoppery@ gmail.com I’d get back to you sooner. Maybe take this to email?

G’day Matt,

Thank you for raising this issue…I have noticed the same issue on my two Tridents. I noticed this a long time ago on my first Trident however it went away by itself (I suspect after an update).

Bill - I connected to one of my ROV’s directly using PuTTY and I used your commands to investigate the directories for anomalies and yes, it seems I have some. For interest sake, I am unable to access the log directory due to permission restrictions.

trident_storageLeak_dir

Here is same issue for my second Trident (sorry for the low image quality - there is 17.9/20GB available)

If the session folder dot prefix means hidden, maybe that’s why the Cockpit app PAST DIVES doesn’t see them.

I know I get the .session folder and a bad 0.mp4 when I disconnect the tether when a recording is in progress.

It might also happen when recording and Cockpit gives the popup about Trident Disconnected - Connection lost. Exiting Pilot mode

There is also a 0.stats file in the good session folders. It isn’t in folders with a dot prefix.

I wondered if the 0.mp4 could be repaired and found How to Fix Video ‘Moov Atom Not Found’ Error.
Free Solutions to Fix Video "Moov Atom Not Found" Error - Stellar
I didn’t have any luck with ffmpeg or Avidemux. If I had a bad video I really wanted, I might pay up and risk downloading one of the other two.

I found the cause of the access issue…I forgot the leading ‘/’ for the log command…seek [correctly] and you shall find hahaha. I note the ‘lost+found’ directory has escalated privileges…has anyone mapped/probed the on-board directory structure for Easter eggs?

I suspect the same re: corrupted video logs and files. I was getting a lot of them in the early days when there were connection issues.

Thanks guys,

I managed to successfully remove the corrupted files from both of my Tridents to restore the full amount of storage.