Trident not found [solved]

After upgrading to latest app version I’m able to connect to the trident WiFi, but the trident is not found by the app. Any ideas?
Have tried on two different devices. Samsung S8 and the trident remote control, same problem.

If I uninstall updates of the app it’s back to normal…
So I guess I have to stay with that original version of the app for now…

I just unboxed my trident last night and couldn’t connect to it from 3 different devices with the latest app version. Tried turning cellular off, which I saw mentioned somewhere, no dice. Thought maybe since I have old firmware on my trident the new app version might not work with it, so my only remaining thought was to try an old app version. Glad to hear a previous version worked for you. I’ll follow up tonight with my results.

Confirmed, reverting to app version 1.5.2 allows me to connect to my Trident. Going to charge and update the firmware and see if the newest app version works.

Updating to the latest firmware on the Trident does indeed allow the newest version of that app to find it. Not sure if that was supposed to be obvious or is documented somewhere, but I didn’t see anything stating not to update unless the Trident has been updated. Hopefully this can help some others out too.

1 Like

I will try that as well. Thanks for your effort.
Does anyone know if it is possible to revert the firmware on the trident if SHTF?

Sofar support help me earlier this week with this issue. They sent a link to downgrade the software to 1.6 on my phone that I use to pilot the ROV. After downgrading I could connect to the ROV, upgrade the software on the ROV and the update the software on the phone again to 1.7.

I don´t know if the link works but this is what Nicole on Sofar Support sent to me.
Here is a link to downgrade your app to 1.6.0


I did that as well and yes it worked…:smiley::cowboy_hat_face:

Link to older software no longer works - please post a working link…