Topside Adapter


#1

OK, so I have finished putting together the ROV and topside adapter. Also, I have put the image onto the SD card which is now in the BB but after connecting the Ethernet cable to my laptop and plugging in the USB cord to the topside adapter, I am finding that I have no middle light on the topside adapter and no lights at all on the adapter beneath the BB. I am currently working to see if this is just an adapter problem. I have lights on the Cape (green solid, red solid and red flashing, plus the blue lights on the BB). Nothing still on the adapter board beneath the BB. Anyone have this problem. Any help would be much appreciated.


Thanks,

Brian


#2

Hi Brian:

If you have all the other lights, but no lights on the ROV Homeplug adapter, then there may be a problem with the 3.3V power supply on the Controller board. The controller board and the BBB run off the 5V supply that is on the controller board, then there is a 3.3V regulator that steps this down further to power the HomePlug Adapter as well as the 3.3V I2C bus (for the depth sensor / compass) and maybe a couple of other things.

You can check all this by using a voltmeter to measure the power supplies on the controller board. Stick some wires in the header J4, which is the 2x8 header closest to the ESCs. Turn the ROV on via the topside adapter, then measure between +5V and GND, and see what voltage you're getting there. Then measure the same between +3.3 and GND.

If indeed you don't have a good +3.3V supply, take apart everything on the E-chassis, and inspect things for shorts. If you have the depth sensor installed, take this off first and retest. Look for shorts in the wiring harness in the 4 wires of the 3.3V I2C bus that go to the outside world. Let us know what you find.

-W


#3

Walt,

Thanks for the help. I did have 3.3V supply. After stripping the E-chassis down, I determined that there must be a problem with the ROV Homeplug adapter. I had an extra Tenda which I stripped down and installed. Once installed and reassembled, I powered everything up and found the new ROV homeplug adapter had lights. Once a reset both adapter there was communications between the two. Now I am in the process of calibrating the ESC's. Again, thanks for the help.

Brian


#4

I am having this same issue and would LOVE some insight! I am building the 2.6 version, and I get the green power light on the Homeplug adapter, a steady yellow/orange ethernet light, and no middle light. I just tested the 3.3V and 5V connections per Walt's description and found good connections there; the board is pulling the right voltage. ALL the lights on the ROV are lit (two green PWR lights, one yellow ethernet light, one steady red on D13 and a flashing light on D49. The BBB is lit up and responsive with blue lights rapidly blinking, and with one green and one yellow light on either side of the ethernet port. When I direct connect the BBB to the computer, the computer recognizes it and pops up and "OpenROV Cockpit" window, which I can click on and view all the files.

Since the 3.3V test showed that it has supply, does this mean that it HAS to be a problem with the Tenda boards? If so, is there a way to test just a Tenda board itself? I don't have any additional items attached to the ROV; I am only working with a bare bones 2.6 version kit, so I don't think it's an issue with a depth sensor or compass (unless those things are already installed on the OpenROV and I didn't know it). After taking apart and inspecting the entire e-chassis a couple of times, I cannot see any visual shorts, but I'm happy to test for others if anyone can provide some guidance. I'm not an engineer, by the way, so the simplest possible instructions are incredibly helpful (like when you tell me where something is on the chassis versus naming it by its technical part number/name).


#5

I had that problem twice. First time it was the connection on the top side adapter. You actually have to squeeze the board together so it’s at a slight angle for it to make the connection, then put some hot glue in between the board and the case to keep it there. The other problem I had was an improper connection between the boards, misaligned the pins. So those are two things you can check

Dave


#6

Hi Neal:

For someone who's not an engineer, you gave a pretty good description of the problem.

I agree with Dave Hinton that it's likely that there's an issue with the mechanical alignment of the Homeplug Adapters, either on the topside or in the ROV or both. The first production lot of the 2.6 Controller Board and the 2.6 topside board used pins that were really a bit shorter than was needed. They will work fine as long as the Homeplug Adapters stay in decent alignment. So I would look them both over, straighten them out if they seem cocked to one side, and perhaps use some double-sticky tape or some hot glue to try to hold them in alignment.

Let us know how that works. There's a small chance you have a defective Homeplug board, but that's actually been pretty rare.

-W


#7

Thank you both for your suggestions! I tried wiggling/reconnecting/aligning the Homeplug Adapters on the topside and on the ROV with no success. No matter how many times I reassembled, checked for alignment, or whatever, I could not get the middle light to turn on. When I first plug in power, the middle light on the topside and the corresponding light on the controller board flash on momentarily, but then they go out and stay out.

The next thing I tried was to buy some jumper cables so that I could at least ensure the connections were good, and because your suggestions made me think that it has to do with the alignment of the boards. STILL I got a steady yellow ethernet light and no middle light. The only weird thing that happened then was, in moving things around, one of the pin jumpers came loose, and the middle light came on. The ethernet light went out, but the middle light came on (see picture). It's hard to distinguish, but it's the connector on the bottom corner closest to the "OpenRov" writing imprinted on the board. I know why the ethernet light went out, but why would this activate the middle light?? I am totally, totally stumped as to what to do next. I have had other people (with actual engineering backgrounds rather than my 7th grade English teacher self) look at the OpenROV and they cannot find any fault with the wiring, connections, or other issues. There are no visible soldering bridges, and there are no visible shorts on any of the boards anywhere. Does that one pin anomaly give anyone any ideas about what might be wrong?



#8

Hi Neal:

Interesting photo. Really interesting.

So the topside interface board is supposed to have two six-pin headers on it. One is for power and LED outputs, the other is the connection to the tether. In your photo, I don't see any pins sticking out of J3 on the upper right part of the board. Perhaps this is a dumb question, but you didn't remove any pins from there did you? I'm wondering if this is just a bizarre failure in the production process, that wasn't caught visually by the person bagging the finished boards.

If that connector were missing, it would produce the symptoms you described earlier.

Assuming that this is the way your board was delivered, we should definitely send you a new one, plus we would like to get the old one returned to show to our assembly house. Please drop David a line (info@openrov.com if I remember correctly) and reference this thread.

Alternatively, if you're the adventurous type with a soldering iron, you can just install a 2x3 header in the J3 position, and I bet your system will start working.

-W


#9

Hi Walt!

OH MY GOD!!! That is a relief in a way (i.e. - that it is not some part of my faulty soldering or something else along the way). No, I did not remove any pins. That is the way this was shipped to our school. If that's all this is, then I am crossing my fingers that putting in a new one will fix this issue.

Another teacher from my school (Nadia) is going to email Dave since she is the teacher who originally received the kit (I've just been helping with the build). The challenge here is that this has eaten up all our "safe time" to test the ROV before our field trip next Wednesday (which we can't postpone). If we get the board by Tuesday, plug it in, and everything else works, we'll be fine. But if we get it then and something else is amiss, then we won't have a functional robot for the trip. At any rate, Nadia will be emailing Dave, and we'll see what we can work out from there. Fingers crossed! :-)


#10

Hi Neal:

Nadia did in fact get hold of David. So we packed up a new topside adapter, and he's just left on his bike to get to the Fedex office in time for today's shipment.

If you want to try something over the weekend, you can try manually making the tether connection between the Homeplug adapter and the Topside Interface Board. If you study the traces on the Topside Interface Board, you'll see that there are really only two connections to the six-pin header J3. Try taking two wires, and solder them into J3 so that they pick up the two connections to the tether connector J2. Then plug the other end of the wires into the matching socket positions on the Homeplug board. Then, power up your ROV and maybe everything will be working.

-W


#11

Hi Walt,

I did try the manual connection you described, but still had no luck. It could be that I didn't have a good soldering connection on those two points. I am assuming I need to plug in both the tether AND the new wires into the posts on J2? When I tried it without that, the e-chassis would not power on. At any rate, I think I'm going to wait for the new part before I try anything. I have low confidence in the homeplug adapter since the 6-pin is missing.