Tilt Servo not responding and a few more questions


#1

Hello,

This is actually my first time posting any kind of forum question, so please forgive me if i miss out on important need to know details.

I am bench testing the electronics for an 2.4 OpenROV kit, BB and Matching cape both white.The camera, thrusters and lights all function, these also function when using the homemade plug (MediaLink). I am running 2.4 stable version. (http://openrov.com/forum/topics/stable-software-for-v2-4-rov) with updated Arduino Firmware.

When i connect the Servo to its place on the BB (followed instruction from http://wiki.openrov.com/index.php/File:CapeWiringDiagram.jpg) it slightly twitches, but pressing the Q,A or Z on the UI does not cause any change in servo position.

I have tried powering the servo directly from the BB and from an alternative power source (an Arduino hooked up to a computer.), keeping the signal wire connected to the BB. I have also tried a different Servo powered separately, same results. (minor twitching but not reaction.)

Lastly the OpenROV cockpit displays a strange set of question marks, where the Depth, Servo and other gauges appear. (see image attached) Not sure if these are related but i thought i worth while mentioning.

If anyone has encountered similar symptoms and can offer some advice, i would greatly appreciate it.

Many thanks OpenROV dudes for enabling such explorations, cheers and keep on diving

Ido.

678-QuestionMarks.jpg (45.6 KB)

#2

Those question marks show that the serial line had noise or another issue that corrupted the transmission. It can happen when uploading new firmware where the serial connection gets cycled. Unfortunately they will stick around until the system is restarted.

Double check the wiring from the http://openrov.dozuki.com/Guide/How+to+Assemble+OpenROV+2.6/6#s179


#3

Hello Brian,

Thanks for the quick response, I uploaded the Arduino firmware again and the question marks are gone. Unfortunately the servo issue persists, the wiring link you attached refers to a 2.6 version, i'm on 2.4 i believe.. (white BB and a white cape)

I am very interested in servo control, i thought of installing a second servo to give panning ability as well as tilt to the camera. Has this been tried before?

Cheers, ido.


#4

Hi ido

Also you need to have the ESC's turned on in order to provide power to the Servo



#5

Hi Ido:

There may indeed be a bug in the camera servo code in the 2.3 / 2.4 codebase- most people are not using the camera servo in these ROVs, since it doesn't have enough torque to turn the whole electronics chassis as it was originally designed. At least a couple of people (Colin Ho and myself) have modified a 2.4 with a camera tilt platform similar to the later OpenROVs, but it has been a while since I have run that ROV, and I'm not even sure I have the latest "stable" build on it.

If you have access to an oscilloscope, it would be good to look directly at the PWM output coming out of the camera servo port, and see if the pulse length is changing when you command changes in the servo position (Camera centered should be a 1.5 msec pulse). Doing this observation will take away any issues of servo hardware. If it turns out that the pulse length does not change, you can file a bug report on GitHub, and we will try to figure it out the next time we release a software update for the 2.4 vehicles.

As to camera panning, note that will the shape of the electronics tube, if you pan the camera it will add distortion to the image. Normally you pan by just pivoting the whole ROV.

-W