Thrusters only rotate in one direction

propulsion
software

#1

I have the 2.7 unit. When starting the cockpit none of the arrow keys that controls the thrusters are working. The only way the thrusters will respond to the arrow keys is when I open the diagnostics panel and set both port and starboard thruster to -1. When pressing the up arrow after this, both port and starboard rotates clockwise and the only way they will stop is by holding the down arrow key or by first pressing 0 or 1 followed by -1 again in the diagnostics panel. There is no way I can make them rotate counter-clockwise.

The problem is similar with the vertical thruster, it will only rotate counter-clockwise when set to 1 in the diagnostics panel and does not stop.

I have tried downloading the latest image to the BBB. I also tried opening and closing the diagnostics panel as described here: OpenROV-ROV-Suite 2.5.1 Final Errants.

It is also worth mentioning that although the 2.7 unit should be shipped with all software pre-installed, this was not the case with mine. I had to manually download the software to the BBB.

Is this a software issue or are the ESCs malfunctioning in some way. Are they perhaps not pre-programmed and/or pre-calibrated as they should be?


#2

Lasers, LEDs, camera feed and camera servo are all working fine btw.


#3

Some things to double check:

  1. Ensure that after installing the cockpit software, you go to settings and upload the matching firmware to the controllerboard.

Also, if things are still having issues, take a look at this post on troubleshooting motors:


#4

Thanks for replying. I did upload the firmware.

Idle values: Motors(1500, 1500, 1500), Mtarg(1500, 1500, 1500), mtrmod(1.0, -1.0, 1.0, 2.0, -2.0, 2.0)

The values changes when pressing the up arrow key: Motors(1662, 1500, 1662), Mtarg(1625, 1500, 1625). But the thrusters does not respond. When pressing the down arrow key the values are Motors(1336, 1500, 1336), Mtarg(1437, 1500, 1437). At this point the thruster still doesn’t respond, but I can hear a beep. When releasing the down arrow key, both port and starboard thrusters rotate clockwise and will not stop unitl I either hold the down arrow key or set the values to -1 in the diagnostics panel.

I also tried the 30.0.0 pre-release, but the behavior is the same.

It looks like both Motor values and Mtarget values respond correctly to my input, but the thrusters live their own life.


#5

Sorry for the delay. Depending on the software/firmware build, there was a while were the work around is to open the settings page and click the close arrow. That resets the mtrmod values.