Thruster/ESC issues


An issue has crept in to my v2.6 unit. I have just finished assembling & installing the new Battery tube bracket system and I have put the entire unit back together. I plug in (turn on the ROV to the computer USB) Stbd thruster starts to run immediately without any control input and before the controller board even finishes booting up. So I go back to the basic ESC programming and calibration procedures as listed in the assembly instructions (and listed below: I start with the Port ESC. I go to the cockpit view and enter “diagnostics” window. I then Start the procedures with steps 1 thru 4 on the port thruster slider on the cockpit calibration window = nothing happens. So I switch to the STBD slider and go through steps 1 thru 4 and the Port motor runs. Next I go to step 5 (on the STBD) thruster slider and = the STBD motor runs. One ESC in two different positions makes two different motors run…?

So…, next I go to the STBD ESC as soon as I turn the switch on (and the slider on the diagnostics windo is set at 0) the Port motor starts to run and the Stbd motor starts to twitch. (again two motors affected by one ESC) When I try to do step 5 the port engine switched direction. When I set the slider to zero the port engine continues to run.

A little history…: the unit functioned properly (with regard to thruster control) in previous bathtub and bench tests. This is a totally new problem. The only thing I did was to disconnect and reconnect the battery tubes. I have run tests with multimeter to ensure that I reconnected the battery tube leads properly and the polarity is correct. The telemetry, light control, camera, laser control, camera tilt servo are all functioning properly.

I have also reloaded the 2.5.1 image onto the BBB. This did not help.

Anybody have any ideas…? PLEASE…

“1) Now that the speed controllers have been programmed we are going to calibrate them. As a reminder the order of the ESCs for the PWM wires are D6-Port, D7-Vertical, D8-Starboard.
2) With all of the ESCs switched off, go ahead and power up. Nothing should happen on the motors. Connect with the cockpit software and open the diagnostic pane.
3) Hold the reset button on the ESC while powering on the first ESC using the switch on the ESC… it should start beeping… let go of the reset button. (It will keep beeping which is fine).
Press reset once and you should hear a single beep.
4) Move that motor’s slider all the way to the right (or click the “1”) and then press the reset on the ESC again. You should get 2 beeps.
5) Move that motor’s slider all the way to the left (or click the “-1”) and then press the reset on the ESC again. After a few seconds the motor will begin to spin.
6) Switch off the ESC and move the slider back to the middle (or click the “0”). Move the next ESC and repeat…”


Still having issues. I thought that there might “possibly” be an intermittent short at the D-25 female plug, as it gets moved around when the e-chassis and camera get slid into and out of the e-tube. So I replaced the d-25 female plug. This did not solve the issue. Troubleshooting continues…



If I were to guess, I’d guess that the Starboard ESC has lost it’s programming. Your text refers to checking the calibration but nothing about checking the programming.

If the ESC loses it’s head and goes back to thinking it’s forwards only (not forwards and reverse), then the ROV’s neutral setting (1500 usec) would cause the motor to start spinning at half throttle.


I’d go back to the step where you program the ESCs, and check that the ESC is still programmed correctly. This is a lot easier if you have a programmer card for the ESCs.

If that looks OK, you might want to look at using a servo tester to see if the ESC is working correctly. Servo testers can be cheaply obtained via Amazon. You just plug it into a servo or ESC, and adjust the dial to get whatever speed or position setting you want. That will tell you whether the motor range goes through reverse-neutral-forwards as it should.

Keep us posted on your progress.



Hi Walt. You have a good point. I’ll try to reprogram the ESC’s. Great recommendation for the servo tester. I thin I am definitely going to add one to my bench. I’m looking on Amazon now. There are certainly a lot of servo testers to choose from. Any recommendations?


Ok, I have attempted to reprogram the ESC’s They all appeared to accept the reprogramming. Next I went to calibration as in step 97 of kit assembly guide (v2.6). I was able to successfully complete calibration sequence on the Port & Vertical thrusters. However, when I tried to do the calibration sequence for the Stbd thruster I had the following issues: When I switched on the Stbd thruster ESC (per instructions) I got the beeps, when I pressed the reset button the beeps stopped. When I moved the calibration slider to the +1 position and depressed the reset on the ESC I got two beeps. I then set the slider to the -1 position and depressed the reset and got three beeps, then the motor began to run only sporadically… Also - when I initially turned on the Stbd ESC, the vertical thruster began to run and continued to run the entire time that I was trying to calibrate the Stbd ESC (note that the vertical thruster ESC was switched OFF). When I switched off the Stbd ESC then the vertical and stbd motors stopped. Is that normal?


…also, and I don’t know if this is related, but the servo that controls the camera tilt does not activate unless at least one of the ESC’s is switched on… I had not noticed that before.


Hey @Ronald_Peters

The question with the camera servo:
Yes, if you switch off all ESCs the camera servo does not get any power and therefore does not move.

If you have troubles with the ESCs, I found I could resolve them by:

  • Switch the ROV off by unplugging the USB connector.
  • Taking the batteries out (both battery tubes)
  • Replacing the batteries
  • Starting the ROV (plug the USB in again)
  • wait for the Cockpit to start.
  • unplug all ESC 3-pin headers
  • Plug the ESC back in that you want to program/calibrate
  • Check that the programming of the ESC is still valid (by going through the beeper sequence)
  • Once done, go into the diagnostics and start the calibration

I had seemingly unresolvable issues with programming the ESCs until I took the batteries out and put them back in. Even though the ROV switches off when the USB is unplugged there is still some power across the controller board and that seems to interfere with switching the ESCs off completely.
Maybe this is a bit esoterical, but that way I could resolve issues.

Hope that helps.


Hi Dominik
Thanks for your recommendation. I did as you suggested and I thought, at first, that it might work. I verified all three ESC’s separately for programming and all appeared to be good. I also did calibration on each ESC/Motor separately as suggested, and each worked as prescribed. However, I then plugged all three ESC’s in and attempted to control the thrusters with the following results:
Initially all thrusters were off (not running).
When I attempted to activate the Stbd thruster the motor started.
I then attempted to stop the stbd thruster but it continued to run.
I attempted to reverse the stbd thruster and it did NOT reverse
I then attempted to stop the stbd thruster (again) but it continued to run.
All controls on the Port and Vertical thrusters appeared to work properly.

All other functions and video appear to function as prescribed, (except the stbd thruster/ESC fiunctions).

Summary of steps taken so far:

  1. Replaced D-25 female plug (thinking that perhaps there was a short).
  2. Verified voltage and polarity of battery tubes.
  3. Re-downloaded and re-installed new 2.5.1 to BBB
  4. Re-programmed ESC’s per Walt Holm’s suggestion but had no success. Problem persists.
  5. Verified and calibrated each individual ESC, per procedures suggested by Dominik and codewithpassion and got mixed results. All looked well during individual program and calibration process, but when all ESC’s were plugged in and turned on the Stbd ESC basically still had issues.

It’s almost like the STBD ESC/Motor can start and run, but once it starts it can not be stopped.

I’m wondering how to verify that the ESC for the Stbd motor is functioning properly (other than the programming sequence)? I’m beginning to suspect the Stbd ESC is the cause of the issue.

Ideas…? Suggestions…? Solutions…?

Ron sends


Hi Ron:

It could very well be a defective starboard ESC. Did you end up ordering a servo tester off of Amazon? That’s really the only way you’re going to be able to tell what’s going on- you have to be able to divide the problem into chunks. With the servo tester, you’ll know right away whether the problem is in the ESC or in the controller board hardware.



Hi Walt.

I ordered a servo tester on Amazon. Hopefully I’ll receive it in a few days.
Maybe then I will be able to isolate the problem. It was strange how this issue came about. I did have everything working properly. I even ran it around the bathtub to test the thrusters and (then) it appeared that all thrusters were working properly.

Thanks again for your help.


Hi again forum. an update on the issue at hand. It appears that the problem is isolated to the Stbd ESC. Here is what I have done today. I have removed the batteries and then replaced them. I have next connected the ROV to the USB port of the computer and let it boot up. Next I have connected to the Cockpit view. I have opened the “Diagnostics” window. Next I have plugged in the Stbd ESC (only) and on to the “D*” header pins as prescribed. I went through all 10 items on the ESC programming sequence and then verified that all 10 items were correctly programmed. Next, I went through the calibration sequence using the calibration slides, as prescribed, and all appeared to go as expected (normally).

To test the progress I left the STBD ESC plugged on to the D* header (as before). I switched the STBD ESC on and the Stbd motor did NOT start. I then used the STBD motor slider on the Diagnostics window to activate the motor which ran forward (when in the +1 position and actually reversed direction and ran reverse when the slider was in the -1 position. However, the motor could NOT be stopped in any slider position. It appears that the “stop” function is not available in this ESC/Motor combination. I’m wondering if it is the ESC or the Motor? How can I test the motor separately???

Thoughts, Ideas, recommendations…?

All other functions (including Port and Vertical thrusters) appear to be working as prescribed.


Ron sends


Well, another interesting development. The issue with the stbd thruster has resolved (at least for the moment) upon trying the OpenRov-ROV-Suite 2.5.1 Finals Errants Workaround “Work Around: Open the diagnostic screen and use the arrow close button to close the screen. Motors should now work correctly.” as described in OpenROV-ROV-Suite 2.5.1 Final Errants

So it now appears to have been a software error… ???

Although now, when I plug in my F310 game pad controller I no longer have access to the dropdown menu for control items (lasers, etc…)