Tether


#1

Hi all,

I have assembled my openrov 2.6 sit step by step as guide says and at the and i can only see camera wiew via cockpit as you can see the attached file. I can not control the Esc’s, camera servo amd leds. Can not control anything connected to the openrov controller board via tether. What should i do? Would you please help me?
320-20140722_021540.jpg (3.94 MB)


#2

Hey Ahmet,

It seems that you've already flashed the Arduino firmware since you have a telemetry feed on the right side, so that's good.

Have you checked to make sure the ESC switches are in the "on" position (each ESC switch should be slide toward the little red button to turn them on). This could explain the motors and servo not working, but would not explain the lack of control for the LEDs. Perhaps those are not plugged in properly.

Another test you can do is to go under diagnostics and move the slider for any of the motors back and forth to see if that moves anything.

Let me know if none of these suggestions work out and we'll keep on trying.

My fingers are crossed!

Eric


#3

I just looked at the image you shared again and noticed that the voltage of your system is displayed as being over 16v! Is that accurate? Your total voltage should be closer to 12v. Your telemetry also is showing no value for most of the voltage and current sensors, so maybe there is some instrumentation error, but certainly that's not what those values should be.


#4

Hi Eric,

We tried them all, when one of the switches are on, all the motors are working. I checked twice and the escs are plugged in the correct order. And unfortunately The diagnostics menu did not move anything,


#5

Actually in our first try it was about 12v with batteries but the problem was the same, after that we used outsource for power and it did not worked,

Is it possible to bring our openrov to you for a check out? Maybe you can see the problem easily. We will be in LA tomorrow, from istanbul and i think you are in Berkeley?


#6

Hi Ahmet

As Eric has mentioned the ROV should be powered with +12V because any higher voltage could result in damage to the ESC's. Because the ROV Powers up with the tether connected and you have video in the cockpit tells me that the tether is working properly. Not seeing any values in the cockpit telemetry data points to a possible issue with the Arduino code not being loaded properly.

1. try loading the Arduino code again making sure there is no errors.

2. there is a keyboard icon on the top of the cockpit that you click on to show you all the keyboard controls. One of these turns off the ESC's so if you hit that key accidentally then nothing will work until you enable it again.

3. When you said the motors work what do you mean by that. What do you do to make them run or do they just spin on there own when you power up the ROV. If this is the case then make sure they are programmed correctly. Then they need to be calibrated in the cockpit which is where you are probably running into issues because nothing is working.

You could also burn a new image onto an SD card and try running on that and upload the Ardunio code. Until you get the image and Ardunio code in sync on the same version you may run into issue like the ones you are experiencing.


#7

Thank you David i will try all and reply as soon as possible after we ll be in LA, if accidentally we burned the controller board can we buy a new one ?

Thank you


#8

I think you are ok on the controller card.


#9

Hi David,

We need thrustfire battery chargers , controller board, escs and may be additional batteries today, we want to come to berkeley and buy some, is it possible?


#10

Hey Ahmet,
Send me an email: david@openrov.com