Tether Problem


#1

We have a 2.5B OpenROV. Everything was working fine on the OpenROV until the last few days.

Recently, we do not get a connection between the top homeplug adapter and the one on the bottom (on the ROV).

  • Only the middle LED blings on the TOP homeplug.
  • The two outer LEDs stay ON on the ROV homeplug.
  • On the ethernet connection of the Beaglebone we have a green and yellow light ON when connected to the ROV homeplug.

Note: when connecting a regular ethernet cable between the PC and the OpenROV (directly to the Beaglebone black) everything works fine.

Any help would be appreciated. Thanks in advance.


#2

Try reseating the Homeplug adapter under the BBB on the control board. it may have come loose.


#3

we did this already.


#4

we also tried reseting the adapters by pressing the buttons... nothing changed.


#5

one other quick try is use a new patch cable between the Homeplug on the Control Card to the BBB


#6

good morning David. we tried using a regular ethernet cable but no success. today we will build another patch cable and try it out. i hope that will work.

in the meantime if you have any other ideas please let me know,


#7

i have another question:

if i have a problem with the homeplug adaptors, can i use the new version of the adaptors (these are the only ones i can find in shops here... i can not find the old ones) with the 2.5B OPenROV? i know i have to make some custom made connections and we do not mind if the homeplug does not fit in the housing of the OpenROV since we are using our own body and we have plenty of space. That mean that the homeplug can be away from the board and can be connected to it using wires we can solder from the homeplug to the board.


#8
  1. We made a new cable for the connection between the BBB and the homeplug on the ROV... nothing changed. same results.
  2. we loaded a new image ... nothing changed.
  3. we redid all the connection on the topside and lowerside... nothing changed.

#9

Hi Giorgos:

From the description of your symptoms, it's not likely that there's anything wrong with your ROV- if the two outer LEDs are on on the ROV Homeplug, it's powered and connected to the BBB, but for some reason is not getting a signal from the topside adapter.

So you need to figure out why the topside adapter doesn't seem to be working properly. You can try resetting it again, and you can try loading the software that came with the homeplug adapters, to see if it can tell you anything about the adapter connection.

Have you checked to see that the top-side adapter is getting clean 3.3V power? On a number of occasions people with 2.5 OROVs have had problems because the wiring of the 3.3V supply in the topside adapter.

Hope this helps.

-W


#10

thanks Walt,

we decided to stop using the homeplugs and designed a new tether that works fine now. we are still turning on the ROV from the USB but without using the homeplugs.

we had to do something fast so we did this


#11

Do you have any other homeplug adapters running at all? Any where in the same network or electrical grid and they can get cross connections.

If the top side plug doesn't have the power led on, but does have the middle on on, that suggests it is not working properly.

Like Walt suggested, test the wiring and voltage of the topside adapter.

The good news RE: using a new version of the homeplugs, is that you don't need to change both of them. If the topside adapter is broken, you can replace it with the new version and just leave the old one in the rov and it should still work properly.