Tether connectivity & power issues


#1

Hi--

Couple issues I haven't been able to troubleshoot, am hoping someone else has sorted these things out and can suggest some solutions!

1) No response when USB and ethernet cables are plugged in to the computer and the topside box. Outer lights flash, but the center light that shows communication does not. When I plug the USB directly into the beaglebone port, it powers up. I double-checked the wiring, and get a solid 5v on tether wires at the DB25 connector. Also get 12V from the battery tubes.

2) Speaking of power, no power reaches the controller board. Found some other mention of this in the forums that suggest shorting J12 - when I do this, I have power and can control the motors/lights/camera from the computer. Is that an acceptable solution, or should it be powered another way?

Thanks in advance,

Todd


#2

Hi Todd,

i had the same problem, my solution was a re-pairing of the two adapter. The connection via the HomePlug adapter now works, as well the Power on/off.

Regards,

Bernhard


#3

Thanks Bernhard. Can you describe/explain how you 're-paired' the adapters?


#4

Hi Todd,

i made the pairing as at http://www.tenda.cn/tendacn/Support/show.aspx?articleid=2230 will be described. Now it works.

Regards,

Bernhard


#5

Hi Todd:

Have you made any progress on figuring out what was wrong with your homeplug adapters? With the symptoms you described (controller board doesn't turn on, no HomePlug communication [no center LED on topside adapter]), it would appear that you have an issue with the continuity of your tether. Yet you seem to have measured a 5V signal on the DB-25 connector. Puzzling. If you're still having problems, can you describe more of the symptoms to us?

-W


#6

(sorry for the delay, was away from the ROV for a while)

So, no luck after trying Berhard's reset suggestion. Still getting 5v at the db25 connector on the tether wires, still getting no power to the bb and no connectivity between the home plug adapters.

When i plug usb direct into the bb AND i short the J12 power, I can open the cockpit and control the motors/camera/lights. It would seem like some issue with the home adapters, but I have no idea what else to test/check.

More ideas?

Thanks,

Todd


#7

I would try to debug the "no power to the BB" issue first, and it may solve the homeplug issue.

Go to the OROV GitHub Electronics site and get the schematic for the controller board that you have (Rev 2.5B?). On page 3 you will see that the 5V across the tether goes to optoisolator OC1, which then turns on the power by (effectively) shorting out J12. So for some reason that optoisolator isn't working.

If you have 5V on the tether DB-25, and the connector is plugged into the controller board, then you should get 5V across capacitor C5, and maybe 1 volt or so across OC1 pins 1 and 2. If you don't have that, work your way backwards towards the DB25 connector until you find out where the issue is.

Let us know how you fare.

-W


#8

Walt -

Thanks for the direction. Not too electronics-savvy, but was able to follow what you suggested

5v at DB25 on both the connector and the relevant pins on the board.

5v at TP21

then no reading at FB1, C5, R3 or OC1. I don't see any other places I should be testing based on my understanding of the schematic - am I missing something? Nothing looks damaged or out of place on the control board.

Thanks,

Todd


#9

Okay, some good clues here.

The 5V coming from the Topside adapter should show up between DB-25 pins 18 and 19. There shouldn't be any voltage on TP21, since (unless you made a custom modification) it doesn't connect to anything right now.

I would go back and review Dozuki step 70, where you wire up the DB-25 connector. Figure out why you have voltage on TP21 and you've probably found your problem.

-W


#10

Walt-

I double-checked the DB25 again, and the tether lines are properly installed in #18-19.

As for TP21, it registers 5v when the positive test lead is on TP21 and the negative is on TP20. Only reason I even tested those is that on the backside of the controller board, one line runs from pin 18 to TP21, not a modification on my part. (not sure what the 'lines' on the circuit board should be called).

Doesn't seem that I put anything in the wrong place, but there seems to be no power getting to the FB1 and beyond. Is it possible the board is the culprit?

Thanks,

Todd


#11

Hi Todd:

Okay, I think I know what's going on.

Go back to your DB-25 plug, take a magnifying glass, and look real carefully at the pin numbers embossed in the plastic by the solder cups. I think you'll find that you've done a mirror image with the connector.

On the Controller board, TP21 is wired to pin 21 of the DB-25 connector.

So go back and check your wiring harness again, from Dozuki step 70.

BTW, lines on the circuity board are called "traces".

-W


#12

Success! You figured it out - had done that row reversed. Now everything lights up and I get 3 lights on the topside box, so it's communicating.

It does not open the cockpit, will see if I can sort that out now.

Thanks for helping me work through the problem and get it solved!

t