Testing For Defective Camera


#1

I have been unable to get a video signal from my ROV. Cockpit shows IMU readings. I have version 2.8. Is there some way to hook camera directly to laptop to make sure the camera is not defective?

Thanks


#2

You can connect your BeagleBone Black (BBB) directly to the laptop, and the camera directly to the BBB. You should get video but no telemetry.


#3

Is it a HD camera? What version of firmware are you running?


#4

The firmware is 30.0.3. The camera is HD.

Thanks


#5

I have hooked up the BBB direct to computer (Samsung laptop) and no video. I also tried it on my desktop pc (HP) and no video. When I hook up the USB cable to BBB, I get the blue flashing lights. When I hook up the Ethernet cable direct, the yellow lights come on. I can ping the network address and get a response, all four packets returned 100%. I tried to use the “SSH” command but I get an “unknown” command error.

How do I use SSH to determine if connection is good? Is there a command in addition to SSH that needs to be entered. Sorry, absolutely no experience in this area so be gentle with the words on any response.

Any ideas on what to do/test next?

Thanks


#6

I’m not sure about it being a HD camera yet. The firmware is 30.0.3

Thanks


#7

I still get no video but I don’t know which program to use to input the feed from the camera. I can’t use the cockpit program as no ethernet connection when hooking direct to BBB. What program or procedure should I use to check the HD camera?

Thanks


#8

If you’re not getting any ethernet connection when connecting the BBB directly to the computer then you most likely have a defective or de-configured BBB. I would try and reinstall the BBB image, as per this tutorial:

If that doesn’t work I suggest reaching out to OpenROV through their support system: https://www.openrov.com/support/


#9

I had my son bring over a webcam and hooked it up to the ROV. I then booted the cockpit and it came up and we had video! Swapped back the camera supplied with kit and cockpit with no video. My first thought is a defective camera but then I got to thinking and was wondering if the supplied IP address, 192.168.254.1:8080 does not work with a HD camera.

Does anyone know if I need to use a different address?

But then, we hooked the webcam to a skype account and had two way video. I hooked the ROV camera to same account and no video.

So, I’m contacting support to see about a replacement camera. Thanks to everyone who replied. Every response was tested, which helped narrow the possible source of the video problem.

Thanks!

Chuck


#10

Try loading and running the 32 version of software and see if it corrects the problem. Note that this must be run with the card in the unit, not flashed.


#11

Thanks for the response!

I can’t find version 32 of the software. The most recent I can find is from December 2015 and is version 31.x.x

Could you direct to me where I can download the version of the software.

Again, thanks.

Chuck


#12

Sorry Chuck, The firmware version is 31.0.? It is not fully released but does help with HD camera issues. If this was an out of the box issue, send a note to “support” and they will get back to you. I have tried a couple of different HD cameras on my unit as the OROV camera would not fit in the custom housing I built.


#13

Hi Chuck,
I’m watching this feed as I have issues myself. How are you progressing?
I am wondering if the camera I have needs replacing, but don’t want to spend time or money needlessly.