Survey: How well does you gamepad work with this test page?


#1

I'm playing with the gamepad API right now. The current javascript library support for the gamepad API is rather drab at the moment, but the code in the gamepad-tester page seems to be using the mapping built in to the browser for the buttons on the devices. I would be interested to know what other gamepads "just work" when using the same gamepad-tester page.

I have the :

  • gamepad: Logitech F310
  • os: OS/X
  • browser: latest canary build of chrome (27.0.1453.12 dev)
  • driver: the OS/X driver.
  • configuration: Using the gamepad in the 'D'irect input mode (vs. the 'X'input mode)
  • result: Every button, pad, and stick worked perfectly.

Please post your setup below and let me know how it works out. If this technique works for everyone on the latest chrome builds, perhaps we can simply settle on this technique for accessing the gamepad going forward.

Note, if your a firefox user, as of 3/22/2013 all of the nightly builds now include the ability to work with the gamepad.

Update 4/5/13: Looks like the firefox feature was disabled pending some bug fixes.


What game pad controller is compadible
[SOLVED] Questions about Trident before pre-ordering
#2

Brian,

thanks for this initative! I'm contolling my ROV exlusively by the gamepad - I think the keyboard option can't be much more than a backup solution.

Are you sure that your gamepad works with the Direct Input mode? I have a (cheap) Thrustmaster Dual Analog 4 gamepad which only supports the DInput mode (like most of the PC gamepads, except the more expensive Microsoft and Logitech ones and few other). I never got it recognized by Chrome unless I used the x360ce emulator software which translates DInput to XInput (see my thread here).

When testing with Firefox nightly build some days ago, it got recognized (x360ce seems not to work here) when I used the gamepad-testing page you mentioned, but the buttons and controls worked only partially and it was not recognized by the OpenROV Cockpit software. With Chrome, I did not try the dev build, so maybe this will run in DInput mode as you reported? I'll give it a try.

Currently I'm fine with using x360ce and Chrome, but eventually I want to go for Firefox because the MJPEG stream is flickering (regardless of resolution or frame rate) every few seconds in Chrome while in Firefox it's running smoothly. So I will buy a Logitech or Microsoft gamepad depending on what other users recommend.

So here is my setup:

  • gamepad: Thrustmaster Dual Analog 4
  • os: Windows 7 (32 and 64bit versions)
  • browser: Chrome 26.0.1410.43
  • driver: native Microsoft Windows 7 driver
  • configuration: gamepad has only DInput mode; translated to XInput via x360ce
  • result: Every button, pad, and stick worked perfectly.

-Stefan


#3

Ah, yes, the current Canary version of Chrome seems to support DInput mode! I'll try this tonight.

http://www.scirra.com/forum/new-chrome-version-supports-directinput-gamepads_topic63838.html

https://www.google.com/intl/en/chrome/browser/canary.html


#4

Just tested the Thrustmaster Gamepad with latest Chrome Canary, without success.

So I'll stick with my Chrome/x360ce configuration.

-Stefan


#5

gamepad: logitech Dual Action (http://www.pcdistrict.com/logitech-dual-action-prod125123.html)
os: OS/X Mountain Lion
Browser: Google Chrome Version 26.0.1410.43
Driver: default OS/X driver
Configuration: none

Result: every button, pad and stick worked perfectly!

However, this same configuration does not appear to work with the OpenROV cockpit software running on my Raspberry Pi.

By "does not apear to work", I mean that the icon on the top right side of the cockpit did not change over to a controller and pressing buttons did not seem to have any effect on the camera tilt icon.

I do not have the cape or motors installed and I'm running the cockpit as "software only" at the moment.

Based on my current setup, it is highly likely that the issue is not with the software....


#6

In fact, I just made "OpenROVController-mock.js"active in the lib folder by changing its name to OpenROVController.js (and changing OpenROVController.js to OpenROVController.js.backup).

With this setup, the controller works great!


#7

bonjour,

we are experiencing no luck with the F310, OSX 10.6.8, Chrome 33.

using the gamepad-tester page, about 5 % of times it accepts the F310, 95% not.

Same for the Cockpit. We installed xbox controller 0.12; there it is not recognized.

using gamepad companion - it is recognized.

the gamepad is put to direct input mode

we were trying to follow the hint below to alter OpenROVController-mock.js - but could not identify it in the arduino open rov software 2.6.

is there some sort of magic switch on the gamepad, which we have overseen,

or any other routine step, which maybe has not been mentioned, but is essential to get it recognized in chrome?

thanks in advance for any hint -

volker


#8

Gamepad Logitech F310

Early 2013 Macbook Pro 13'

OS Yosemite 10.10.1

Google Chrome Version 38.0.2125.122

Config: gamepad in "D" for Direct mode (specifically have to do this for mac's I read somewhere? anyhow, it's the little switch on the gamepad)

Result: everything works out of box, plug and play.