stk500_recv(): programmer is not responding


#1

So i finally managed to update the BB and directly I ran in to the next problem...

When I try to update the cape (from the cockpit) everything seems to work until it's trying to restart and update the firmware. I keep getting the message "stk500_recv(): programmer is not responding". I've browsed the forum for a solution but to be honest I really don't understand anything of the possible fixes suggested.

I don't have another arduino to play around with so i'm pretty muxh stuck with what I've got from OpenROV. Is there a working fix for this problem and if so could someone please describe it in a step by step instruction?

I'm so damn close to have this thing working now so this really feels like a splinter in my eye! I've got picture from the camera and i'm running on the latest cockpit (i think, atleast i have the capture button etc). But no response from the servo, motors or light so from what I've understood so far i need to update the cape.

Thanks in advace

Erik


#2

Okay, some bit of progress.. I managed to understand how to update board.txt from 56700 upload speed to 115200.

By doing this the firmware update to the cape worked a little better, it continued the installation after the first reset but after the second it started to put out errors again. So i tried again, but this time it didn't work after the first reset again.

So I tried the other thing, updated "upload.py" with the '-vvv' command. But that didn't help, it still didn't want to complete the installation.

But now i get a continous red light from the cape and i can control the lights, the motors and the servo moves a little when i try to change it. One motor is continously running though and I can only get it to stop by changing the manual test of the motor.

So any ideas? :)


#3

Belive it or not but I actually managed to make the script update thingy suggested on the forum and after 3 tries with that the script completed installation of the cape!!

I still have problems with motors continously running though. So i still need help :)


#4

did you do an ESC throttle point calibration? Out of the box the ESCs have neutral points that may or may not be the 1500 microsecond PWM pulse that the Cape gives it. You'll need to to do the procedure outlined at the bottom of this page

hope this helps!


#5

Thank you, I had missed that part. However when I tried this just now it went fine for calibrating the first 2 motors then everything froze up.

And now the whole shobang freezes up as soon as it boots up (the verical ECS light up green and the other 2 lights up red) so I have to turn off all 3 ESC's in order to get in to the cockpit. As soon as I try to start one up the BB and Cape restarts.

If i try to calibrate 1 of them all 3 ESC's light up and the software feezes again. Something has gotten really messed up. Is there ayway to rollback and start over?

If I have all ESC's offline I still can control lights and see picture from camera but tilt servo is not responding either.


#6

Could you possibly put up what you did? I have the same exact problem, and I just cannot find a proper solution.


#7

Hi, it all worked out for me in the end.

First problem was that the batteries was running out of juice which made the BeagleBone and Cape run out of voltage when it all started up (due to the fact that all motors started running at full speed as soon as i started 1 of the ESC's). So when I changed the batteries it stoped rebooting as soon as I tried to do something.

The other thing that took me a while to understand was that I calibrated the wrong ECS in the cockpit. When I reseted the ESC for let say port engine I thought it was starboard and started to adjust that one in the cockpit which made everything go nuts.

So I labeled everything with some paper tape and a pen; the motors, the ESC's and the connectors on the Cape in order to make sure that I adjusted the correct ECS in the cockpit.

After that everything worked out as it should.


#8

Oh, wait a second, you were talking about the firmware upload?


#9

Yeah I meant the firmware upload. I just keep getting the "stk500_recv(): programmer is not responding" error no matter what I tried.

I've changing the upload speed, the '-vvv' option, but neither works for me. The cockpit upload does not work with either attempt.


#10

Well i did the script solution that i found here on the forum. You create a script in /opt/openrov/arduino/Openrov/ that does the upload from within Ubunto instead of the cockpit.

I tried to find the exact same code i used again here on the forum but can't seem to find it. The information is a bit scattered through different threads on the forum.


#11

My ROV is out of batteries again so I can't log in and copy the script for you, but as soon as I have it up and running I will paste it here for you.

I had to run the script a couple of times before it worked.