[SOLVED] Wireless Logitech 710 and wired Dual Action gamepads not working with OpenROV 2.7


#1

Having trouble getting my gamepads working with my OpenROV 2.7. Both gamepads connect and work via http://www.html5rocks.com/en/tutorials/doodles/gamepad/gamepad-tester/tester.html and I’m currently using the current Chrome version 44.0.2403.89 m.

Neither of the gamepads appear to register with the Cockpit and I’ve tried connecting them before/during/after loading the Cockpit and have tried all the different functions and modes the controllers have to no avail. I’ve had no issues using the keyboard controls.


#2

I have also had issues with the current version of chrome not recognising the gamepad (wired xbox controller) and found that the gamepad had to be plugged in prior to chrome being opened, if any chrome windows are open when you plug in the controller, it will not register and you have to close and re-open chrome for it to work.

Once it is registered, I have found the latest version to be more stable with the controller and have not had any other issues (in older versions I would often get one random button not working or intermittent button function). Don’t forget that you have to press a button on the gamepad once the cockpit is loaded to enable it.


#3

I’ve re-tested by connecting the controller before opening chrome and still have no results. Again, no issues with them responding via the API tester, but Cockpit isn’t picking them up still.


#4

Issue still not resolved, unable to find solution.


#5

I tried using both logitech F310 and 710.For me F310 is very unstable and sometimes not even responding, but 710 works flawlessly on my laptop. For me, I will plug in the 710 wireless port before I turn on my laptop and press Y or A on cockpit to connect it after the rov connected to laptop( and a small controller logo will shown beside the setting button) .


#6

I fixed my controller issue, for some reason the version of the gamepad API that was included in the cockpit source was incomplete or out of date, after updating it with the latest version my issues were resolved.