[SOLVED] V2.6 Lights will not turn on

electronics

#1

I Recently completed construction of the V2.6 and successfully updated the software to version 30.0.3. Everything is working except the headlights. I can unplug the lights from the board and connect them to an external power supply and they work fine. With the lights unplugged I checked the voltages on the P1+ and P1- pins at the connector and it ranges from 9.5 down and up as expected when controlled by the console o and p keys. However If I set the light control on full (9.5v) and plug the lights in, the voltage drops from the 9.5v to around 1.65v (no lights). Its like the board cannot supply enough current to drive the lights. I can achieve the same result with the lights in a standalone configuration connected an external variable power supply, leaving the voltage set to 9.5v the LEDs will light and dim to off by decreasing the supply’s current adjustment.


#2

A couple of questions:

  • Did the lights work before you updated the software to 30.0.3?

  • When you hooked the LED lights up to an external power supply, how much current did they draw?

The power PWM channels are generally pretty reliable, though it’s not impossible that you’ve got a bad one for some reason. You might want to download the schematic for the 2.6 controller board from the OpenROV GitHub site, and I can help to walk you through the PWM circuitry.

-Walt


#3

Thanks for responding Walt. The lights have never worked which is one reason why I tried upgrading to 30.0.3. The upgrade went smoothly as expected. Everything else seems to work fine. Although I really haven’t checked the IMU yet. But all motors, the camera, the laser measurement lights, and servo work fine. When the lights are unplugged from the ROV and connected to the standalone power supply the LED lights appear to draw 40 mA. I have the lights with two square pads with 9 LEDS on each. I downloaded the 2.6 schematics.
Bill


#4

Hi Bill:

If you have the 2.6 schematic, then you can trace out where the current for the lights flows, and measure each step with a voltmeter to see where the issue lies.

Look on the top left of sheet 6 and you will see the circuitry that drives the lights (PWM1). Starting from the (+) battery bus (called V_BAT on the schematic), current goes through R28, to PWM1+, returns via PWM1-, and then through Q4 to ground. I’d take a voltmeter with one side connected to a ground test point. With the LEDs plugged in, turn the lights on full in software, and then probe at all of these points. If you’re only getting around 1.6V across the LED board (PWM1+ to PWM1-), then there must be about 8V of drop somewhere else. When you find that voltage drop, you’ll know how to fix the issue.

Let us know how things work out.

-Walt


#5

Hi Walt, I’m not a EE but my guess is that Q4 is bad. It looks to me like Q4 is never fully turning on, so “PWM 1-“ never drops below around 8.5 V and hence the voltage difference presented to the lights is around 1+ volts . I measured the voltage at R26 to be 9.4V.
I measured the voltages at the Drain and Gate of Q4 for each bar of the illumination setting and got the following.

Bars__D__G
8__ 8.5__3.5
7__8.6__3.12
6__8.7__2.68
5__8.6__2.23
4__8.8__1.79
3__8.9__1.34
2__9.3__0.9
1__9.3__0.45

I put a scope on the Q4 Gate and the signal there seems to be working as expected.

Lights Off

1 Bar

7 Bar

On - Full Brightness


#6

Hi Bill:

Yep, Q4 is probably bad. If you’re handy with a soldering iron, it shouldn’t be that hard to replace. The transistor is easily available from Digi-Key (see the BOM on the GitHub site if you need the part #), or, if you figure you’re never going to use PWM channel 4, you can try desoldering Q7 and moving that good transistor over into the Q4 slot.

-W


#7

Bill:

One idea to try before desoldering Q4 is that perhaps one of the leads has a cold solder joint on it. Try pushing on Q4 while you have the lights enabled, and see if that causes them to suddenly turn on. Or, just resolder the 3 leads of Q4 with fresh solder. If neither of those things work, then you probably have to pull Q4 off and replace it.

-W


#8

Thanks Walt, I had already tried resoldering but no effect. I did find the part on digikey and ordered it. I’ll let you know how the repair goes. Thanks again
Bill


#9

Received the new part today and with great eye strain managed to get the old part out and the new part in. It took a while. The lights are now working!! Thanks again for your help Walt, I really appreciate it!
-Bill