[SOLVED] Two Motors Ignore ESCs?

propulsion
solved
sos

#1

Hey fellow OpenROV enthusiasts! After wrestling with this problem for awhile, I must concede that I need help. Details: http://rayhightower.dev/blog/2014/08/19/openrov-assembly-challenges/

Summary of Symptoms

With the cockpit software running and attached to the OpenROV:

  • If I turn on any of the three ESCs, two of the motors (vertical and port) start running at full blast. The starboard motor remains stationary.
  • While the V and P motors continue to run at full blast, the starboard motor responds to the cockpit slider controls as expected: +1 makes S run full blast on one direction, -1 sends S full blast in the other direction, and 0 stops the S motor completely. During this exercise, V and P continue at full blast.
  • Turning off the ESC stops the V and P motors.
  • When I turn on any of the ESCs, the camera servo jumps slightly, about 10 degrees. And then the V and P motors run full blast.

When the cockpit software is not running (and the Google Chrome browser is completely closed):

  • Turning on an ESC has no effect on the motors.
  • The camera servo jumps slightly, about 10 degrees, as it did with the cockpit software running. But the motors remain stationary.

Interesting behavior!

More details and previous troubleshooting steps are here:

http://rayhightower.dev/blog/2014/08/19/openrov-assembly-challenges/

Thanks,
Ray


#2

Hey Ray,

Can you confirm that you have successfully programmed and then calibrated the ESCs. Two different steps: http://wiki.openrov.com/index.php/Programming_the_ESC


#3

Hey Brian: Thanks for the reply! Yes, the ESCs appear to be programmed correctly. I bought an ESC program card to verify this. My verification steps are in the blog article.

Since you mentioned calibration, I'll double-check that step as well.


#4

Update: Brian, your RTFM advice worked. I missed something last time I did the calibration. Blog article coming soon. Thanks!


#5