[Solved] Trouble with updating the beagle bone, can't get into cockpit anymore

solved
sos
electronics

#1

Forgive me as I haven't worked around linux based systems for quite a few years so I may need some handholding -- that being said I followed the wiki's instructions to update as I'm having trustfire cut outs and I was hoping the update would get the latest version as I saw there was an update to rovpilot.js which could help fix it. For reference, I have a v2.6 openrov kit.

I got into the shell and started the update script and everything went fine until it gave and error saying that it couldn't get the file


fatal: unable to connect to github.com:
github.com: Name or service not known

./update.sh: 5: ./update.sh: /opt/openrov/updatelinux.sh: not found
npm WARN package.json sync@0.2.2 No repository field.

> serialport@1.2.5 install /opt/openrov/node_modules/serialport
> node-gyp rebuild

gyp http GET http://nodejs.org/dist/v0.10.17/node-v0.10.17.tar.gz
gyp WARN install got an error, rolling back install
gyp ERR! configure error
gyp ERR! stack Error: getaddrinfo ENOTFOUND
gyp ERR! stack at errnoException (dns.js:37:11)
gyp ERR! stack at Object.onanswer [as oncomplete] (dns.js:124:16)
gyp ERR! System Linux 3.8.13-bone30
gyp ERR! command "node" "/opt/node/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /opt/openrov/node_modules/serialport
gyp ERR! node -v v0.10.17
gyp ERR! node-gyp -v v0.10.9
gyp ERR! not ok
npm ERR! weird error 1
npm ERR! not ok code 0

it ended up unpacking a previous update I guess, then I tried a manual update which was unsuccessful as well. The wiki had me move the original openrov to an openrov_old dir which I moved back and tried the update process again which had the same error. I tried starting up the rov system which appeared to work with no errors, but I can't connect to it via port 8080 any longer. Also I don't have access to a SD card reader currently, so I can't update that way, anyone have any suggestions?


#2

Realized it was a internet connectivity issue, got online and did the updates but the updates didn't complete, all though the open rov node can be launched, I still can't connect to the cockpit. This is the update error that I got:

./update.sh: 11: ./update.sh: /opt/openrov/cockpit/linux/arduino/firmware-installfromsource.sh: not found
* Starting OpenROV NodeJS server openrov * ---> started OpenROV NodeJS server openrov [ OK ]
./update.sh: 13: ./update.sh: /etc/init.d/dashboard: not found
root@OpenROV:/opt/openrov# /etc/init.d/dashboard: not found
bash: /etc/init.d/dashboard:: No such file or directory


#3

Solved it! Ended up getting an SD card and reader and just burned a new image and it worked fine afterward


#4

Woot!


#5