[solved] Trouble connecting to cockpit after software update

solved
software

#1

Just downloaded 2.5.1 and burned it on to a micro-SD. Installed the micro-SD in to the BBB SD slot. turned on the ROV and let it boot up for about 5 minutes. Attempted to connect to cockpit with some success. Had telemetry, light control laser control, camera tilt control, motor control, but no video… So I disconnected and turned off the cockpit and rov. I then attempted to reconnect and now I am unable to open the cockpit. When I turn on the ROV I get flashing lights on the ROV and on the Topside adapter looks good. Just no Cockpit connection. Suggestions?


Instructions: Burning SD card image on windows
#2

Let me know if I can do something to make the guide more obvious for those facing connection troubles


#3

Ok, my problem with making connection with 2.5.1 openrov cockpit appears to have resolved itself. I shut everything down and walked away for about an hour. When I came back and started everything up, there it all was. Connection looks good, I have video and all controlls function… Don’t know what I did right/wrong, but now it’s working so I’ll take that as a good sign… :smile:


#4

Hi Brian, I apologize for the question, but I am not a tech/software expert, so I dont know how to reload software images, or what things like terminal command prompt mean. I connected to the ROV once and everything appeared to be functional. Put simply, I now can not reconnect. I have checked all the settings and connections, and they seem to be fine. The message I get from Chrome is that the webpage is unavailable: coded ERR_CONNECTION_REFUSED. Again, I apologize for the question…just looking for a demystified way to troubleshoot my problem.

Thanks

Charlie


#5

Hi Charlie, I too am having the same problem so I would be interested in any responses you get for a solution. I have assembled my 2.7. I powered everything on yesterday and checked EVERYTHING out and everything functioned properly (lasers, lights, motors, IMU, everything…) I was attaching my IMU to the body and suddenly lost connection to the unit and cannot seem to resolve it. When I power it on, the unit lights up, I get the flashing blue led from my BBB, and all three LED’s on the topside box are lit up, but the unit will not connect. Sometimes I get flashing lights, and sometimes I don’t. I’ve tried checking my internet settings many times and looking for anything out of the ordinary and cant seem to find anything. Somebody help us!!!

-Harry


#6

@Charile, @hdwebb

How far did you get through the troubleshooting guide?


#7

I got it squared away, Thanks!!! Following your instructions, I looked for the cylon-esque LED pattern and never got it. I re-flashed the BBB with the 2.5.1-final software, and voila we’re back in business. For the record it took over 8 1/2 minutes to re-flash, so you might want to let people know to wait longer than 5 minutes before restarting.

I tried searching the forums for 2.7 connection problems and never found the troubleshooting information so thanks for the troubleshooting directions… IMMENSELY HELPFUL!!!

-Harry


#8

@badevguru Hey Brian,
I just downloaded the image from the site. It does not show up as a zipped folder however, but an img.7z file. Can this image be directly written to the sd card? If not, what do i need to do to unzip this file so it can be written to the sd?

Thanks for all the help, i am close…i can feel it!

Charlie


#9

@badevguru Hey Brian,

Connected! Thanks again for all of the help.

Charlie


#10