[Solved] Struggling with ESCs

propulsion
solved
sos

#1

Hello gang :)

I'm almost done the build on our version 2.6 ORov and for the past few days, I've been struggling with the ESC/Motor control.

By isolating each ESC and only having one plugged in and turned on at a time, I can successfully program and calibrate the ESCs. Once all 3 are plugged in, I appear to have full control of all 3 motors.

The problem comes when I then plug in the Camera Tilt servo into D11. At that point, some ESCs lose their programming and calibration. Some will not respond at all while other do in only one direction (but somewhat erratically). Also, the tilt servo will only operate in one direction from center. Any ideas what could be happening and how to correct?

Can someone also recommend which stable software rev I should be using?

Many thanks in advance for the help.

Charles


#2

I had a chance to work on this again and managed to successfully program all 3 ESC and calibrate the Port and Vertical ESCs. The Starboard one remains problematic.

I was about to try swapping the Port and Vertical ESCs to narrow down the possible issue.

In the process of removing the ESCs from the board (a little heat from the heat gun goes a long way here) I was able to get a good look at the indicator leds on the ESC. My troublemaker has both green and red leds on solid at power on. Reseting will not make them come off; I suspect I have a bummed unit.

I have replacements in transit and am hoping to receive those soon in order to confirm the theory.
1-image.jpg (907 KB)


#3

Charles -

I am also building a 2.6 and have been down a very similar path as you; erratic thruster behavior somewhat remedied by unplugging the camera servo. With only the ESC's plugged in (D6,D7,D8) , I have fully operational STBD and VERT thrusters, but PORT only twitches and chatters and will not turn a full revolution. I can program PORT, but am unable to calibrate it.

Fearing a shorted or broken wire, I installed a brand new PORT thruster. But even the new PORT motor still chatters.

---

All ECS's are programmable, but behave somewhat differently:

-VERT ESC tones (when programming) and LED's light appropriately - thruster works fine

-STBD ESC does not tone, lights appropriately - thruster works fine

-PORT ESC does not tone, lights appropriately - thruster chatters

(If I didn't know any better, I'd say the tone actually comes from the thruster motor, not the ESC?)

---

The only other PORT ESC symptom is that occasionally the red LED freezes 'on' after issuing keyboard commands. The only remedy is to power cycle the entire system.

---

Additional ESC troubleshooting :

I removed the PORT ESC, leaving only the STBD and VERT installed on the board:

PORT ESC removed

STBD ESC installed

VERT ESC installed

This configuration resulted in the PORT AND STBD thrusters chattering?! Vert thruster worked fine. With only two ESC's installed, three thrusters were affected?

After reinstalling the PORT ESC, VERT thruster sill worked fine, STBD worked fine, and PORT went back to the only thruster chattering.

---

Wiring Troubleshooting:

I reheated all ESC connections just to make sure there were no cold or shorted joints.

I also checked to make sure that there were no shorts in the DB25 connector.

---

As for now:

I remain stuck with two out of three operational thrusters, and have still yet to plug the camera servo back in.

---

Charles - would you mind sharing what you learn with the new ESC?

Any further community input would be most appreciated!

Thanks!

Shaun


#4

Hi Shaun:

You've got an interesting set of symptoms there. Maybe I'm misunderstanding your text, but I can't figure out how (under the topic "Additional ESC troubleshooting") the port thruster can be chattering if there's no ESC installed on the controller board. Where is power to the thruster coming from?

Have you done any more work over the last week to try to narrow down the problem?

-Walt


#5

Shaun,

The only way I can think you would get a response from all three motors with only two ESCs installed is if you have the wiring crossed over between motors (though without a additional short somewhere, I would have expected that all three motors would chatter at best).

If you have a multimeter handy I would start by checking the wiring from the DB25 connector to the motors. Disconnect the D25 connector and measure the impedance between the three motor windings (i.e ESC1A to ESC1B, ESC1A to ESC1C and ESC1B to ESC1C) for each of the motors in turn. You should measure a few hundred milliohms in each case. If you get an open circuit for any of them, you have a wiring problem. Next measure the impedance from each of the motor windings (again from the DB25) to those of the other two motors, if it is not an open circuit, you have a wiring problem.

Let us know what you find.

Adam


#6

Hello Shaun

Apologize for the delays but time seems to have gotten away from me. In big part, due to the ORoV expedition vehicle we are putting together :) Check it out...

https://openexplorer.com/expedition/swimwithbluefintuna

As far as ESC updates.. replacements have been deliverer for me at a friend's across the border, with any luck, I'll have them in hand and installed early in Feb.

Will keep you posted.

~ Charles

UPDATE: My issue was caused by a defective ESC. It was replaced, the latest software was loaded, ESCs were setup and calibrated and all appears good to go!


#7

Hello Charles,

I am curious what version of the software you have flashed on the BBB. I was having starboard motor issues as well with OpenROV-flash-2.5.1-39 flash onto the BBB but when I used OpenROV-2.5.1-108 booted directly from the card the issues went away. My issue was with my starboard motor as well. Have you tried booting from the card with the newest software?

Brett


#8

Brett,

That is very strange. I have tried every combination of the three software files on the main OpenROV page both flashed and booted directly from the card and the only one I can get to consistently operate the thrusters properly is 2.5.1-39 booted from the card. Anything else I try usually looses reverse on one or more thrusters either immediately or on the first reboot. I think i am going to stick with this for now. I have far too much time invested into trying to make this work. Perhaps the next update will resolve our issues.

Also, I noticed in your other thread that you have to hold the button down on the Beaglebone. I don't have to do that and never have. I thought I read on the BB website that holding down the button on boot up told the BB to copy the card to memory. This whole thing is quite confusing to me as there seem to be muliple ways to do things and I am not sure of the positives and negatives of each method.


#9

Hi Harry,

It is my understanding that you need to hold the boot button next to the SD card to boot off the card (I could be wrong as I can’t find any instructions on the OpenROV site or forums). I am more of an arduino guy than BBB so it’s new territory for me. My other understanding is you can SSH into the BBB when booted off the eMMC and changing the name of the U-boot.img will force a boot off the SD card. Good tutorial here. http://www.twam.info/hardware/beaglebone-black/u-boot-on-beaglebone-black I will keep you posted about my config.


#10

Per page 15 of this document-

http://learn.adafruit.com/downloads/pdf/beaglebone-black-installing...

the user boot button is supposed to write the image to onboard memory.

As far as I can tell, mine is booting from the card every time. I have never pushed that button, but if I remove the card I will lose reverse on one or more thrusters.

Further searching does turn up conflicting information about the button. Its very strange that it works one way for me and another way for you...


#11

Walt -

Thank you for chiming in....please see my comment to Adam (below) for a followup on my homework.

Much appreciation!

Shaun


#12

Hi Adam et al! Thank you for your responses.

Good News:

Removing the DB25 and testing impedance revealed a bad wire on the PORT motor. I replaced that wire, and now show 0.07ohms between windings on each of the respective motors.

I also found that there were no shorts between motors.

---

The PORT motor still chatters. It spins somewhat more than before and responds directionally when fwd/rev commands are given. But the chatter is still pronounced.

The VERT and STBD motors work fine.

---

Troubleshooting further, I turned all ESC's OFF. None of the motors worked when issued commands.

I found that with any single ESC ON, and the other two OFF, all three motors get power. Which I thought odd. In other words, with only one ESC ON, all three motors behave as if all three ESC's were on. Doesn't seem right.

I metered the blue OpenROV Control board at J14,15,16 and found continuity between the three ESC GND's. I also found continuity between the three ESC PWR's.

I did not find any continuity between the A,B,or C pins on their respective ESC's, or between the ABC pins the other ESC's.

---

I also uploaded the latest cockpit software 2.5.1 announced here (http://community.openrov.com/profiles/blogs/new-rov-cockpit-software-released) and am running off of a SD card on the BBB.

Any ideas where to go from here?

Thank you again to all that have chipped in.

Shaun


#13

Hi Brett

I have been running (or trying to run) OpenROV-2.5.1-31. Are you able to email me OpenROV-2.5.1-108 as I cannot seem to locate that one; I'd love to try it. you can reach me by email at laforge.cj (at) gmail.com

Who can recommend the latest, or perhaps greatest, stable software release to run?

Charles


#14

Hi Shaun:

Sounds like you're making progress.

The odd behavior when you switch only one ESC on is due to the fact that the BEC (battery eliminator circuit) from the 3 ESCs are ganged together, so that +5V power is provided to the camera tilt platform, and whatever other servos might be plugged into the controller board, if at least one ESC is turned on. When only one ESC is on, it back-drives 5V into the other ESCs, partially turning them on.

With regards to the port motor chatter, I think you're going to have to do something to narrow down the issue to either the motor or the ESC, and unfortunately that's going to require some desoldering/soldering. First I would go back and measure the resistances of the port motor wires from the DB-25 very carefully, using an ohmmeter that has a resolution of 0.1 ohm or better. What you're trying to figure out is whether one of the lead wires of the motor (which is stranded) has some of it's strands broken, making the motor electrically unbalanced. If the port motor does have some broken lead wire strands, you might want to replace the motor before the lead wire breaks altogether.

If that doesn't find anything, then take your DB-25 connector and swap the wires between the port motor and the starboard motor. When you plug everything back together, notice which motor chatters. If it's the port, then the problem is with the motor or it's wiring. If it's the starboard, then the problem is with the ESC.

Keep us posted on how your testing goes.

-Walt


#15

Hi Charles,

at the bottom of this page http://www.openrov.com/products/2-7.html it shows the v2.5.1 ROV SD card image download. When you download it it is listed as 108. I updated my post as well. Once I got my motors to program (which I could only do off the card it seemed) they will malfunction on the next startup until I open and close the diagnostics screen.


#16

Hey guys. I am having the same types of symptoms. Just now trying to get a handle on it.

I don't get it (maybe a dumb question) but I dont see any SD card. Is this internal or a physical sd slot.? Am I missing something.


#17

Yeah I should stop calling it a SD card. It’s a micro SD card slot on the side opposite to the Ethernet.


#18

Hi Walt -

You nailed it!

During my previous rounds of homework, I installed a new PORT motor. With the trouble shooting advice from you and Adam, I was able to verify that resistance across all motor windings is the same...so all motors are good.

With your latest help, I swapped the PORT and STBD wiring on the DB25....resulting in the problem switching motors. The PORT now runs nicely, and the STBD chatters.

So I think that solves the mystery...one bad ESC needs replacing.

As soon as I get a new one in place I will let you know how it goes.

Thanks so much, Walt!

Shaun


#19