[SOLVED] Software update "There was a problem loading the branches!"

solved
software

#1

Hello,
I have a 2.6 version, the software prompted me to do an update from the browser. After waiting for while, I get this error message:

Uh, there was a problem loading the branches!
{"data":"","status":0,"config":{"method":"GET","transformRequest":[null],"transformResponse":[null],"url":"plugin/software/branches","headers":{"Accept":"application/json, text/plain, */*"}},"statusText":""}

Currently installed software versions

openrov-arduino-firmware - 1.0.1-50-g0d0eacc-master
openrov-avrdude - 6.0.1-4
openrov-cloud9 - 0.7.0-4
openrov-cockpit - 2.5.1-rc1-87
openrov-dashboard - 2.5.1-47.9f498c
openrov-dtc - 1.4-4
openrov-ino - 0.3.6-9
openrov-mjpeg-streamer - 2.0-6
openrov-proxy - 0.1-19-19
openrov-samba-config - 0.1-5

Has anyone seen this error? Do I have to do an update from SD card? Thank you


#2

See this topic about the update procedure to 30.0.0. It is probably easiest to just use an SD card in order to get to 30.0.0.


#3

Thank you. The upgrade from SD card worked fine. (the flash to BBB however was not very successful, but I didn’t try again since burning the image to the card worked well)


#4