[solved] ROV work on land, but not in seawater

power
solved
sos

#1

Hi everyone! I’m having some trouble with the ROV which I’ve just completed.

Thought I would share my experience for reference, and hopefully also get some valuable feedback.

After finished building OROV#730, it was time for a sea trial. Did a pressure test first without electronics, dropped it overboard in my boat for 2 successive dives, first to 28 meters, then to 38 meters, both successful. Plan to repeat this before going any deeper with ROV.

Then it was time to test the ROV with electronics onboard and see how it went. After a successful ride in my bath tub I was feeling optimistic.

But, once the ROV got in the sea it only took a minute or so and it died. Cockpit froze up and comms were lost. This repeated itself several times. Sometimes the motors died, other times the video was frozen up, and other times I simply lost communication. The few seconds it did work video stream was jitterish, with low update rates. For comparison, everything was fine onboard prior to submerging it and after a reboot on deck.

The same happened on the second sea trial the next day. It worked fine out of the water, but same problems occurred when submerged in seawater.

Back to the drawing board!

Since the ROV works fine in dry air, but consequently fails in seawater, poor electrical insulation somewhere comes to mind as the culprit. So I decided to do a test.

I poured water into a bucket large enough to contain the ROV and added salt into water to simulate seawater. I removed the electronics from the tube and disconnected the 25 pin connector. Then I submerged the aft part of the ROV, ensuring that motors and wire


bundle was under water.

Then I did an insulation test between the individual pins on the 25 pin connector and the salt water using an Ohm meter. Ideally one should read indefinitely resistance between connector and the salt water outside. Probably would have received other results if I had megged it, but I don't have a megger, so went with what I had. The results are shown in the table below:


OpenROV #730

Resistance results - salt water leakage test

PIN#

NAME

Resistance:

1

ESC 1 A

16

Mohm

2

ESC 1 B

15,7

Mohm

3

ESC 1 C

15,4

Mohm

4

GND PB

6

Kohm

5

BAT 1+ PB

26

Kohm

6

BAT 2+ SB

25

Kohm

7

GND SB

Indefinete

Mohm

8

ESC2A

Indefinete

Mohm

9

ESC2B

Indefinete

Mohm

10

ESC2C

5,4

Mohm

11

ESC3A

4,8

Mohm

12

ESC3B

5,3

Mohm

13

ESC3C

6

Mohm

14

+3,3V

216

Kohm

15

SCL

220

Kohm

16

SDA

223

Kohm

17

GND

226

Kohm

18

TETHER A

Indefinete

Mohm

19

TETHER B

Indefinete

Mohm

20

TP20

Indefinete

Mohm

TP20-25 are sealed

21

TP21

Indefinete

Mohm

with glue gun. They

22

TP22

120

Kohm

are spare wires.

23

TP23

230

Kohm

24

TP24

240

Kohm

25

TP25

237

Kohm

Reference value: Measured between both test probes in salt water: 2.8KOhms. Note that the exact values need to be taken with a pinch of salt (literally) as they took a while to stabilize. They also varied a bit dependent on the area of test probe in contact with water. But it shows the trend.

I suspected initially that either tether or the motor wires had poor insulation, but as the test shows, they appear to be fine.

The battery compartments are the ones that show highest conductivity towards salt water, with port minus pole showing only 6KOhm resistance to water.

Have inspected the battery wire, but cannot see any damage to it, nor is it spliced anywhere.

The IMU module did not perform very well in this test either, with about 220 KOhms for all wires. Question is, is it the glue lined heat shrinks covering the soldering joints that are the culprits, or the epoxy not sealing properly around the wires and board? And should the relative low resistance on the IMU be enough to halt the whole ROV?

I’m a bit uncertain where to pursuit this, I guess I could redo the splices on the IMU, I’m out of glue lined heat shrink, but have ordered more.

Meanwhile, I think I will test the ROV in a nearby lake in freshwater to see if I encounter the same problem there.

Has anyone else seen similar problems, or have some suggestions to fix the problem or things to test?


#2

I suspect that the motors draw more current when they are in water and that your unit is losing min required voltage as a result.


#3

Hi Armand

I am very interested in your results as I’m getting close to putting 778 into the ocean. I once worked with motors and rewinding and know what salt water can do to electronics. I agree with you that the motor connections seem to be OK. I don’t understand why your battery connections test so poorly. I suspect that they are fine when out of salt water. Your wire could have flaws in it, I have seen this before. I would dry out the battery tube and wire then connect up the ohmmeter and slowly drop in salt water to see when the readings change. I think I would unsolder terminals 20 to 25 as well. Next I would disconnect the IMU and try it. Keep us posted on your results

Dave


#4

Hi again and thanks for the input from you both.

Rick, I thought of the same problem myself, it has been known to happen, have seen some post in the forum which is caused by this. I don't believe this is the case here though, I have always had full batteries, and started off with a low motor speed setting like 3 or 2. And what I observed was that motors died, whilst videostream continued, so the Beaglebone did not shut down. I also experienced frozen video without excessive use of motors.

Dave: A millenium ago I worked as an ship electrican trainee on a chemical tanker. One of my tasks was to megger the electrical motors. Once salt got into them, values would drop, and we had to spray them with Electro Clean. So when I first saw the consept used here in OpenROV with soaking the motors in water, I had my doubts. But it principle, if you get everything sealed up it should work. But that can be easier said than done.

I did a test today with the bucket of saltwater. Started up the ROV in air, did system check, everything worked, and then lowered it into the bucket of saltwater. Immiately I got problems with the vertical thruster. Even on motor setting of 1. It turned a little bit, then died. The forward thrusters worked better. So I suspect there might be an issue there with the vertical thruster.

I then decided to do some more field testing, if nothing else, it is more fun So I went to a local lake, and tried the ROV there. Freshwater after all is better than saltwater in terms of conductivity. The dive went fairly successful. The thrusters worked fine and telemetry and video also. The only thing was the update rate, which was at times rather lousy, with down to 4 frames per second, and sometimes it froze up for a second or two. I think some of that may be contributed to the laptop, which i suspect may be struggling with the task at hand, specially since I recorded video also. But even when I did not record, the update rate was slow.

Video of the test can be watched here:

http://youtu.be/-Y3NthYguJY

You will notice the slow update rate at times.

IMU: Data came in here most of the time, but did occationally freeze up as well, but video and control remained. I rebooted a couple of times and data would come back. The depth data persisted throughout the dive, only compass and pitch, roll etc that froze up. So the data link from IMU did come through, just the IMU part of it that did not always work.

Once back in my workshop, I decided to do some extra work on the potting of the battery compartments since they were showing lowest resistance. It's also an easy fix, so I started there by adding some more E-90FL.


See picture.

Things to test next:

-Re-test resistance test to see if the values for battery tubes have improved.

-Redo the soldering and heatshrinking on vertical thruster. (once I get more heatshrink)

-Try another laptop to see if refresh rates and quality of video improves.


#5

Got hold of a megger, and retested the resistance values between 25 pin and water with 250 volt.

Basically it shows that all motor connections have minimal insulation towards seawater.

The port battery module is not showing too good for Ground.

Also the IMU module is not very good either.

Weird that all motor wires show poor insulation. Having bad luck with one of the soldering, heatshrinking jobs is one thing, but all of them is suspicious.

Would be interesting to see what results other folks got on this if they megged the motor resistance.

PIN# NAME Megger 3 march
1 ESC 1 A (P) 0 Mohm
2 ESC 1 B 0 Mohm
3 ESC 1 C 0 Mohm
4 GND PB 20 Kohm
5 BAT 1+ PB ok >50 Mohm
6 BAT 2+ SB ok >50 Mohm
7 GND SB ok >50 Mohm
8 ESC2A (V) 0 Mohm
9 ESC2B 0 Mohm
10 ESC2C 0 Mohm
11 ESC3A (S) 0 Mohm
12 ESC3B 0 Mohm
13 ESC3C 0 Mohm
14 +3,3V 0 Mohm
15 SCL 0 Mohm
16 SDA 0 Mohm
17 GND 0 Mohm
18 TETHER A ok >50 Mohm
19 TETHER B ok >50 Mohm
20 TP20 ok >50 Mohm
21 TP21 ok >50 Mohm
22 TP22 ok >50 Mohm
23 TP23 ok >50 Mohm
24 TP24 12 Mohm
25 TP25 ok >50 Mohm


#6

Armand,

I'm sorry that you're having these trouble, and it's a very interesting phenomena you're noticing. We've used several ROVs in seawater that have worked great, but on a recent dive in saltwater we noticed a similar behavior- we noticed that when we moved the port thustor, the ROV would die (presumably from a short that browns out the computer).

Assuming that water was leaking in under the waterproof shrink tubing, we stripped off the heat shrink and redid it, but this time we also coated the solder joint with hot glue before placing the shrink tubing over the solder joint.

In a little salt water tank we have, we did some additional testing and our repair seemed to have fixed the problem, but more testing is still needed.

Please let us know if you get to the bottom of what's causing this- it seems like this could be an issue other people might encounter so knowing a good solution would incredibly valuable!

Thanks for the help and the great data!

Eric


#7

Hi Eric,

Thanks for the reply. I suspect this problem will be something other builders will encounter as well, so worth keeping some focus on.

When I did the heatshrinking of the motor leads, I noticed that the heatshrink did not entirely shrink around the wires from motor windings. Probably due to the smaller diameter of the bare wire compared to the insulated wire to electronics tube. Tried to apply glue afterwards to the ends, but it probably was too late for a proper seal.

I followed the building instructions for version 2.5. I noticed that in the building instructions in 2.6 that came later, you have added the use of glue gun to the motor leads prior to sealing with heatshrinks. In heinsight this appears to be a good thing to do.

I will redo the motor solderings and heatshrink and do it the "2.6 way"

Probably will redo the heatshrink for the IMU as well, since I only had a small bit of heat shrink left to do this at the time.

I shall post the outcome of the fix.


#8

That sounds great. I'm very excited to hear how it turns out.

Good luck!!

Eric


#9

Hi all

Talked with a fellow today who described splicing 25KV lines and then laying them in sea water. They coated the butt splice with silicone grease, then heat shrinked it. They did this 3 times per splice. These lasted 2 years with no problem. I would think that if we just put on a single coat that should be sufficient. I’m going to redo my connections with this process and see how it works.

778


#10



Hi again,

I have redone the wiring for the motors, soldered them and heatshrinked them after applying glue over the solderjoints with heat gun. I took it a bit further as well.

For starboard motor I also pottet the whole foundation of the motor with gluegun. See picture.

For port motor I tried to just pot over the motor with glue gun without re-doing the soldering and heat shrink.

As far as vertical thruster goes, I completely replaced it with a spare motor I have, and did the soldering/heatshrinking as per 2.6 instructions. (Second picture)

Then I meggered all motors in seawater again as per procedure described earlier in this link.

All motors showed close to 0 resistance, or full leakage to saltwater...

I have discussed this with Kjetil, who also is building at the moment, and he tested his motor prior to assembly and also got full leakage to water.

He observed that once the metal of the mounting base touched water insulation dropped to zero, even before the windings got in touch with water.

Would be interested in seeing what values someone with a functional ROV got if doing this test. Maybe you never will get good resistance on the motors whilst in water, but just "good enough" to get it to work?

Anyway, decided to do a test, set the ROV into a small tub with saltwater, sufficient to submerge it, and it worked fine apperantly. Motors worked and video worked fine together with telemetry.

So the next day I tested it in my hot tub in the garden. Total failure!

Motors stopped working, telemetry was slow, and video froze up.

Back to testing more...

I notice Dave's hint about silicon grease, but based on Kjetil's observations it may seem that it is not necessarily the splices that cause the leakage.

Maybe I'm barking up the wrong tree all together.

Since I observe occasional trouble with telemetry and video without engaging motors, it could be that something else is causing the problem. Maybe the tether is damaged somewhere close to the ROV, since it worked in the small tub (where tether would be dry) and did not work in hot tub and sea water (where more of tether would be wet)

Further testing will hopefully show. (Once I get back the enthusiasm to continue)


#11

Hi Armand

One thing you can try is to install the jumpers to turn on power to the ESC's & Contoller & BBB so you do not have to rely on 5V across the tether to turn on the ROV. If this works for you then you know that the issue is with the Tether.

Regards

Dave


#12

Hi Dave,

Thanks for the tip. My thoughts were that damage to tether was distorting the telemetry more than the DC part of the signal, but you may be on to something. Will keep it in mind during further troubleshooting.


#13

Hi Armand:

This is really interesting.

Can you measure continuity between one of the motor leads and the metal mounting base, while the motor is in air?

It may be that some of the motors have a short between the windings and the mounting base. We might be able to measure this before installing the motor in the ROV, and then would be able to avoid this problem.

-W


#14

Hi Walt,

I tried what you suggested.

Port motor showed 5 MOhm on the megger @250V for all 3 wires.

Starboard motor showed more or less short towards mounting base on all 3 wires.

Vertical motor showed infinite resistance on all 3 wires, in other words it seems okay.

The latter is the one I replaced with the spare I purchased.

I also tested the motor I replaced, this one also showed short circuit between all three wires towards base of motor.

So basically all 3 motors that came with the kit are shorted

:-/

Seems like I need 2 new motors.

A warranty issue?

Thanks for the tip Walt, Don't think I will get any further with this until I have replaced the motors with some that show good isolation.


#15

Armand, yes. I'll get more motors out to you. Thanks for your help identifying this issue.


#16

I tested mine. There was only one that have leak. Will send you an E-mail.


#17

Hi,

I did some tests on my motors: I put the motor into salt water, and I measure the resistance between the ESC wire and the water.

On 3 different generation of motors I get:

- 1 to 9 Mhoms: direct purchase onto hobbyking

- 100Khoms: first kit of openrov

- 150Khoms: upgrade for motors from openrov

The measure appears as soon as the base of the motor touches the water...

What do you think of these value? Do I have a leak?

Please note that in the air, I have no resistance between the wire and the motor base...

Thanks for your help!

Regards,

787-photo31.JPG (90.5 KB) 788-photo11.JPG (97.3 KB) 789-photo21.JPG (96.9 KB)

#18

Benoit:

I think you'll be fine. The motors we see that cause bad problems have a resistance of 1 or 2 ohms between the windings and the base.

-W


#19

I have changed out the leaking motor. I have megged all three motors without any leak to the base of the motor. I still get software freezing after approx 3 min. In both dry and wet condition. When it freeze Im unable to reset it by disconnecting the usb. I need to disconnect both battery and wait more than one hour (after I have tested I disconnected the battery over night then Im able to get contact with the cockpit, but it freezes after 3 min again. Have tried again today and disconnecting the batteries for approx one hour, unable to get contact with the cockpit, so I need to have the batteries disconnected somewhere between one and 8 hours). I have tried two different computers with the same result. Have repeted the issues at least five times with the same result every time.

What can be the issue?


#20

Hi,

My ROV works fine in shallow water. But just at a few meters depth the current consumption rises and then the connection freezes. I suspect it is the same motor problem as reported here.

When I measured the motors, however, all three showed several Mohms against the base.

After playing with this a bit, I was able to provoke a shortcut by removing the propeller and squeezing the motor against the base with pressure on the side with the wires. The same thing happened on all three motors. This makes me a little reluctant to just replace the motors. Does anybody else have the same experience?

FT