[SOLVED] Rant - I HATE LINUX!


#1

This is a big rant. I’m sitting here at 10 o.clock at night, having started trying to flash the BBB with the latest software (or is it firmware? - who gives a s**t).
I think people that enjoy grovelling around in the command line mud are weird. You type it in character by character and then it replies with No such file or directory. Oh dear, got a space in the wrong place! So you type it in again and get it slightly wrong, but you can’t move the cursor back to correct it. So you cut and paste from notes and it doesn’t like that. It is 30 years since I programmed in assembler and there really isn’t any need to do this stuff now.
It’s a bit like cutting the lawn, only you think it’s more macho to dismantle it, take the blades out and use them to cut each blade of grass. Why not use the whole lawn mower? Why not program in a slightly higher level language?
I want to look at stuff underwater, I don’t want to waste my evenings trying to get round the finer semantic details of how the f****ng spanner works.
OK , rant over, but I’m going to bed really miserable.


#2

Sorry you’re having trouble updating the software! Can you provide some more details about what exactly you are trying to do and what instructions you were trying to follow? There shouldn’t be any need to use the command line to update either the Beaglebone software or the Arduino firmware, so depending on which operating system you are using, I can give you some straightforward instructions that use UI tools instead of the command line.


#3

Thanks Charles
Evidently the GUI will only go up to 30.0.0 and to update to 30.0.03 you need to use terminal on the Mac. I’m trying to update the BBB software.
I’ve followed Brian’s excellent instructions about flashing an image to a microSD but when I put it into the BBB I don’t get flashing lights.
It seems to put the image onto the card but the I get an error message saying the disk is unreadable.
I guess I’ve probably messed up the existing 30.0.0 so how do I go about putting a fresh, bootable version on the BBB?
Thanks
Andrew


#4

Alright, I can see where you might run into problems. Two things I’d like to check first:

  1. Did you download your latest image from here: http://www.openrov.com/products/2-8.html (bottom of the page, 30.0.3, Flash version)

  2. Did you make sure to extract the .img file from the .7z archive before using the dd command?

Assuming you’ve done both of those things, you might want to give this tutorial a try, which uses a UI tool called PiFiller:

It is designed for the RaspberryPi, but will work perfectly fine with a Beaglebone Black. Of course, be sure to use our image file and not the Beagleone Black image mentioned in the tutorial.


Checklist: Burning an image to an SD card on OSX via the command-line
#5

Thanks Charles, I used:
v30.0.3 ROV FLASH image
and unzipped it as recommended with The Unarchiver.
I will try PiFiller now.
Thanks


#6

OK, now I have written the image to the card with PiFiller.
I’ve plugged it in to the BBB, Powered up. Power light comes on but none of the 4 lights by the USB port are doing anything.


#7

First try unplugging it and plugging it back in. The user lights do take a few seconds to turn on.

Alternatively you can try the 30.0.3 SD card version.

For this one the system will boot from the SD card so you should leave it in wait for everything to load and then you should be able to connect to cockpit and flash the firmware.

There also could be an issue with your physical hardware.


#8

Look like it might be working. I plugged it in again and rebooted. Now the 4 lights are flashing like crazy.
Fingers crossed.


#9

This is with the Flash version?

It will take about 10-15 minutes for the process to complete.


#10

Yes, the flash version.
Just about enough time for a cup of tea and bedtime malt Whisky.


#11

Hey guys,
I’m now the proud owner of version 30.0.03!
Thanks for all your help.
Phew, it’s nice when it stops.
G’night all.


#12

Glad to hear that you were able to get it successfully installed.

Make sure you also upload the firmware onto the Arduino. See Steps 15 and 16


#13

It says in step 15, SD card should not be in the ROV. Where should it get the new firmware from?


#14

The firmware files were loaded onto the BBB when you did the install from the SD card to the BBB. The firmware update takes the files from the BBB and puts them on the arduino.

The button “Upload firmware from SD card to Arduino” in cockpit is mislabeled.


#15

OK. Thanks Brian. That seems to have worked. I think that should be a bit more clear in the instructions.
Thanks for all your help. I still hate Linux!
Andrew

p.s. I’m a LabVIEW programmer. Easy Peasy, you spend 10 minutes, you write a whole GUI!

Cheers.


#16

Glad that you got your software updated. The community is hear to help.

I have some ideas to make the OSx directions a little easier to navigate through and will hopefully get some new ones up next week.

Have a good night!


#17

This topic was automatically closed after 24 hours. New replies are no longer allowed.