[Solved] Problem Uploading Firmware to Arduino

solved
sos
software

#1

Good Day All,

I've been having an issue (I think) while trying to upload firmware to the arduino via the cockpit. It just seems to hang forever (>15mins) on the following step. I've tried doing this from two computers, reloading the image, and repowering the ROV. All I really want to do is to set the motor direction, but it should work.The image I have is 2.5-29 (if I recall correctly) I'll double check when I get home.

Any ideas?

Thx,

Mike



#2

Hey Mike,

On the last general release we still had a bug around the serial io that would occasionally run in to race condition. In my experience it has been intermittent.

The issue was https://github.com/OpenROV/openrov-software/issues/175

If that looks like a fit, you might try the latest dev image which has the fix... but might have some other issues sense it is still a dev build: https://github.com/OpenROV/openrov-image/releases/tag/v2.5.1-DevImage2


#3

Thanks Brian! Will do.


#4

Hi Brian
Yesterday I tried master 44. the upload of the Arduino software was much faster, which made me happy. I had to reboot several times however to get everything to work. After each boot something else was working or not working (for example motors respond to sliders in diagnostic, but not to keyboard or gamepad, yawing left used both motors, yawing right only one and so on) Hard to understand.
Another observation I made was that the imu-functions were rotated by 90degrees. So if I lift the front, the cockpit shows a tilting sideways. Is that a bug or did you intend to mount the imu 90degrees rotated? (Its like using microsoft products, you never know wether its a bug or a feature) :wink:
Thanks for all your work!!!
Hub


#5

I uploaded master 48 this morning. It addressed the firmware upload. :) Like Hubertus mentioned, the IMU functions are rotated by 90 degrees.

While testing/configuring, I noticed there seems to be a lag between pressing buttons and having a response from ROV. It looks like the cpuUsage is 1 or very high. Sometimes the motor stay on after I stop pressing the arrow keys. I'm assuming it is because the CPU is busy and not seeing the key-up.

I disabled the head up menu hoping to free up resources, but it didn't seem to do too much. Are all of these features/plugins putting too much strain on the BBB? Any other things that can be done to improve performance?


#6

Hey Mike and Hubertus,

Glad it is working. The CPU utilization is driven primarily from the USB not being interrupt driven on the version of the Kernel we have used. We are testing the upgrade and hope to release it soon.

In the meantime, you can lower framerate on the video if CPU becomes a big problem.

As far as the IMU goes, yes, it is currently askew in the dev image. Will be sorted out soon.


#7