[solved] Power up troubleshooting

power
solved
sos

#1

I have finally gotten the time to make progress on my ROV!

But, on power up test, my ROV does not light up/power up.The homeplug leds 1) for power and 3) for connectivity to my pc turn solid greeen. 2) does not light up.

My ROV does not any leds lit at all. Batteries are charged and show 12v.

This is for ROV v2.5 & step 80 (http://openrov.dozuki.com/Guide/How+to+Assemble+OpenROV+v2.5/2) in the guide.

Any suggestions?


#2

Hi Joe:

If you've got an OpenROV 2.5, make sure that your topside box is putting 5V USB power over the tether wires. See the diagram on Dozuki step 78. You should be able to measure 5V where the tether connects to the topside box.

If that's OK and the unit still doesn't turn on, go back to the wiring of the DB-25 connector, and make sure that you have it done correctly. It is very easy to mirror image the DB-25 connector and end up with the tether leads in the wrong places. If that still looks good.......well write back at that point.

-W


#3

Hi Walt,

Thanks for the reply. My voltage at the homeplug adapter is 4.66V. My homeplug adapter led adjacent the power adapter is lit and seems to indicate the ethernet from my laptop is connected. The led furthest away is also lit and seems to be a power indicator. The middle led, however does not light up. Nor does my OpenROV indicate that it is powering up. Thoughts that occur to me... my homeplug adapter is broken. Or ? Voltage on the batteries and terminals is good.

Thanks,

Joe


#4

Hi Joe:

The homeplug adapter doesn't play any role in turning on the ROV. 5V is sent down the tether to the controller board, where an optoisolator sees that voltage and turns on the battery power. You won't get a center LED on the topside adapter until the ROV turns on. So....

Go back and carefully check the connections on your DB-25 connector. It is very easy, and quite common, to attach the wires in a mirror image of what is correct. If that happens, then the ROV won't turn on when 5V is applied to the tether.

-W


#5

Hi Walt,

I went back to the DB-25, verified the connections, verified that the port and stbd measure 12.46V & 12.49 respectively at the DB-25. Checked the tether connections on the DB-25, performed the startup again. Then switched the tether terminals on the homeplug and tried again. I removed all other connections from the DB-25 so it was just the stbd & port batteries & tether. Still no startup...

On the positive side... I always learn more when things don't work right the first time.

Any thoughts?

Joe


#6

Hi Joe:

If the DB-25 connector is wired right, the batteries are charged, and you have voltage on the tether, then the ROV should be turning on. So it's time to dig in in more detail.

Go download the schematic for you controller board off of our GitHub site. The power switching circuitry is on sheet 3 of the schematic.

Find optocoupler OC1 on your controller board- if you hold the board with the DB-25 connector on the left, it's on the lower right side of the board. With the controller board plugged in and power on the tether, measure the voltage between pins 1 and 2 of the optocoupler. You should be seeing about 1 volt or so. If there's no voltage there, then you need to trace the circuitry back to the DB-25 connector to see why the tether voltage is not getting through.

Keep us posted on how your debugging goes.

-W


#7

Hi Walt,
The problem was my topside adapter. Solved!
Onward!
Joe


#8