[SOLVED] OpenROV 2.8 will not power on after build (urgent)


#1

So, we’re shipping out to Guam in 3 days. I was hoping to take the ROV as part of our toolkit for a study but it’s not looking good. I’ve built it over the past 3 days and would consider myself fairly proficient (no expert) with electronics/wiring etc.

So far I am stuck on the step where you plug the Ethernet and USB cables in and “watch it come alive”. The latter didn’t happen at all. I have checked -

Battery voltage (all good at 3.7-3.8V)
Voltage from topbox (4.8V)
Topbox shows two lights, middle is not lit.

I went back over the electronics steps and made sure everything was done correctly which is was but still nothing from the unit at all. All my connections are well soldered.

Does anyone have a starting point of where I can look for potential problems?

It’s a 2.8, was delivered about 2 weeks ago. I am using the Neutrally Buoyant Tether too.

Thank you!


#2

Hi:

As you may or may not know, the ROV is turned on by placing a 5V signal onto the tether. This signal turns on the main power switch on the ROV controller board, allowing battery power to flow to the electrical circuitry. So if your ROV is not powering on, either there’s something wrong with the battery connection inside the ROV, or for some reason the voltage is not running down the tether to turn the unit on.

The first thing I’d check is to see whether the batteries are getting power to the ROV. If your ROV is fully assembled right now, undo the main tube from the ROV, and pull off the acrylic tube so that you can work with the E-chassis while it’s still plugged into the endcap. On the controller board, find the empty (unstuffed) connector location named J12. If you’re looking at the board with the DB-25 connector on your left, it will be on the lower right side. It’s also marked “Pwr switch” or something like that. Anyway, take a short piece of wire and short the two leads of J12 together. This should turn the ROV on, regardless of whether you have the topside hooked up or not. If the ROV turns on, then you have an issue with continuity in your tether. If the ROV does not turn on, then there’s probably an issue with battery power not getting to the ROV. I’d download the 2.8 Controller board schematic off of our Github site to help you with any debugging you might need to do.

Let us know how your testing efforts go.

-Walt


#3

Thank you for the fast response. Shortly after posting this I found the db25 pin out. I tested both port and starboard banks and found zero volts.

After quite a bit of head scratching I saw the batteries weren’t even making contact with each other. I guess my coworker ordered the high capacity batteries but neglected to tell me that they needed modification prior to use. Anyway, I modified them and on she came.

Again, thanks for the fast response.


#4

Glad that you got the problem solved. For those who are puzzled over the battery comment, here’s a Dozuki article about prepping the batteries. Although the article is about the high-capacity batteries, I do this with the white standard batteries as well. In a nutshell, size 26650 batteries are made to be tabbed together in battery packs, not slipped into battery tubes. To get reliable battery contact in tubes, you need to remove a bit of the heat-shrink insulation off of the bottom, and maybe add a dot of solder to the top battery contact as well.

-W


#5

Thank you for the tip re: shorting the J12 connector to troubleshoot power issues; it was really helpful.

I wanted to test the OpenROV’s electronics before potting the electronics, so I assembled my 2.8, successfully powered it up, disassembled it and then applied the epoxy resin. However, on reassembly, it didn’t work; it seemed absolutely dead. I checked the electronics again, but couldn’t find a break in the connection, and then found this post on the forums. When shorting the J12 didn’t turn the OpenROV on, I checked the battery connections carefully and discovered that the epoxy had dripped through both battery tubes and had coated the spring-connectors completely, insulating the batteries completely. Since the tubes had already been epoxied, I tied the soldering iron to a long screwdriver, and used this makeshift tool to burn the solder off the springs. The OpenROV then powered on successfully.

-Shashank


#6

@Shashank_Srinivasan:

Glad things worked out for you.

-W