[Solved] No video feed, ROV-reboot sometimes fixes this

solved
sos

#1

Hi!

Slowly progressing with v. 2.6. Cockpit connects fine, controls works OK, basically everything works fine but video feed does not come on every time, I have the impression that 1 out of 6-7 tries work. Curiously, pressing "f" shows a frame rate varying between 30 and 40. I guess that the video is actually fed but not displayed. I run Windows 8 and Chrome (IE behaves the same). BBB and arduino updated w/o problems.

Someone recommended restarting the video streaming process on the pc. What name shall I look for in the process listing?

Ideas anyone?

/Richard S


#2

Hi Richard,

You can verify that the mjpeg streamer process is running with:

ps aux | grep mjpg

You should get back two entries, the first being the full command line of the mjpg-streamer process and the other being the grep command iteself.

Does simply refreshing the browser seem to fix the issue? You can isolate it to a browser or beaglbone issue by using a third party mjpeg viewer such a vlc. If you use VLC and open a network connection, you can enter http://192.168.254.1:8090/?action=stream and you should see the video.

-Brian


#3

Thanks for the prompt reply!

When i SSH into the beaglebone as rov there is no MJPG process running, just the grep command

VLC from my PC also fails.

/RS


#4

Okay. The video is on our short list to make more robust. I suspect there is a timing issue with the services right at startup when the USB is till doing some initializing or something. The quick fix from the UI is use dashboard to stop and then start the cockpit process. When cockpit starts it kicks off the mjpeg-streamer process. Optionally you can use the command-line noted in this post: http://community.openrov.com/forum/topics/useful-command-line-commands


#5

The command line works OK. In a previous life (>10 yrs ago) i used to do UNIX admin at my alma mater... so it brings back fond memories...

>The quick fix from the UI is use dashboard to stop and then start the cockpit process

How is this done?

Thx,

/RS


#6

That dashboard is on http://192.168.254.1

There should be options to stop and then start the cockpit service.


#7

Of course... I should have figured that one out... :)

Thx

/RS


#8