[solved] No response from servo or motors

solved
sos

#1

I'm currently at step 97 in assembling my ROV: http://openrov.dozuki.com/Guide/How+to+Assemble+OpenROV+2.6/6#s259

I've been able to connect to the ROV, and I have gone through the ESC programming sequence, and everything is responding correctly. I was going to start the ESC calibration face, but allas no response whatsoever. I've tried rebooting the ROV, still no response. There is certainly power going to the ESC's since I've been able to do the programming part. There is power going to the motors too, because while doing the programming the motors would do the beepety bop thing and twitch a little for every beep.

The servo don't respond either.

Lights are controllable, and I have video feed.

Any suggestions?

186-ScreenShot20141005at21.38.37.png (1.87 MB)

#2

The reason the camera tilt servo doesn't respond is that all the ESCs are turned off. The servo is powered through the BECs of the ESCs, so if they are all turned off, then the camera tilt servo won't work either.

Can you be more specific as to what happens when you try to do Dozuki step 97?

-W


#3

Hi Walt, when I did the programming, everything went as expected: the motors did the beeping, there is a LED light blinking on the ESC simultaneously, and there was a little bit of twitching on the motors themselves as the motor beeped. So as far as I can see, there is power going to the motors.

But when I try to "move" the ROV using the arrows, I get absolutely no response from the motors, even if the software seems to responding: the motors, mtarget and fthr telemetry is responding to keyboard input. I have double checked that the ESC's are plugged in correctly, and are as follows:

ESC 3 - D8

ESC2 - D7

ESC 1 - D6

Servo - D11

When I follow the Dozuki step 97:

  1. I start the ROV with all motors off,
  2. Then switch on one of the ESC's while holding in the red button.
  3. It starts beeping, upon which I release the red button.
  4. The ESC continue beeping, as expected.
  5. Then press the red button once, upon which the beeping stops, but without the additional final beep, not as expected.
  6. Then moving the sliders in any direction in the diagnostics pane does not render any response at all.

I have not yet installed the lasers or the IMU, but I don't understand how that can be the reason.

-Roy


#4

Ok, this was my bad, had the ESC / Servo plugs turned around the wrong way. I see now that this is reflected in step 66, I had just not read that part, I guess.

Problem solved!


#5