[Solved] Need help with 2.6 ROV#1478


We finished the build of our ROV few weeks ago, but have been having problems.

After build, I had updated the BBB and then in turn the Arduino fw with package
Also followed the post-build checklist and re-ran the ESC calibration routine several times.

When I start up the ROV I find that my vertical thruster only works in down mode.
My Port thruster also refused to engage in forward mode.

I had initially thought this was an electrical short issue, though I found nothing. I’ve resoldered my rs232/db25 and now sealed in liquid electrical tape. I don’t see any other sources of potential shorts.

Here is the interesting thing I am noticing:Usually if I toggle fly-by-wire setting, everything seems to work for awhile until I lose camera feed. Also the camera feed does not return even after restarting the cockpit service. Seems I need to to a full reboot to get everything working again.

Any thoughts or guidance…??


This sounds like a known issue from this older software version.

I would recommend updating to the latest software version, currently 30.0.2. Here are the directions for that process.

A quick software update might be all you need.


Thanks Brian, I’ll update to 30.0.2 and let you know how it goes!


Hi Tony
We had the same difficulties when we first brought our 2.6 on line. It’s a program thing. Best to download and install the latest Cockpit program. Things should work fine then… Good luck.


So last weekend I updated my firmware to 30.0.2, it alleviated the issues I was previously running into, however brought in some other minor issues.
-Intermittantly I find that the illumination LEDs continously flash(as if it thinks I’m not connected) and the simulated connection led on the lower left of the cockpit turns red. Even though I am connected and can control the ROV.
-Also, it seems to lose connectivity w
ith the camera.

I was able to complete stage one of my tank test, however, I powered off and moved outside to stage two of my test (in a garbage barrel) and was never able to get the BBB to boot back up fully. Did not find any signs of water, I’ll have to stick and console monitor on the BBB and see if it has any console messages.



Glad to hear that the software update solved most of the issues. The issue you are now seeing sounds like a known issue which you can read more about on the GitHub Issue #450.

On the BBB do you see the 4 user lights in the cylon pattern?


Brian, I couldn’t verify the cylon pattern.

Once I restarted the ROV for my stage two tank test, I wasn’t able to reach the BBB or even ping it’s IP… I plugged a console to it and can see the filesystem is felgercarb…:slight_smile:

I installed the fw on an older BBB rev A6A that I had laying around and that seems to work to get 1478 back in action.


Glad to hear you got your ROV up and running. We have been working on the reliability of the BBB.

closed #9