[solved] Issues with motors on OpenROV-flash-2.5.1-39 but not OpenROV-2.5.1-108

solved
sos

#1

Hello,

I have been working on getting my 2.6 up and running and was having intermittent starboard motor calibration issues. It programmed fine once using the flashed software (2.5.1-39) but mostly it would 1)run all the time with the other ESC enabled 2) be twitchy 3) Run forward fine but not reverse

Here is what I debugged

- I ran through the motor trouble shooting guide multiple times to limited success (I only got it working right once last night).

- I checked each motors for shorts ala Walt's suggestions here http://community.openrov.com/forum/topics/starboard-motor-spins-slower-than-port-after-successful There weren't any that I could detect

- I reflashed the BBB and uploaded the arduino multiple times to no effect (including redoing the SD card)

- After each reflash I recalibrate the motors in all the different possible orders VSP, PSV, SPV,VPS which made no difference it seemed still a weird starboard motor.

- Tried the flashed version in a single chrome tab after a reboot so as not to run into any memory issues didn't help

What has worked is using the bootable SD card (booted by holding down the boot button on the BBB). To double check I restarted the system without holding down the button (which I assume gets me back to the flashed software) and I had calibration issues again.

Is there anyway to get the BBB to boot from the SD card without holding down the button?

My system

MacBook Pro (15-inch, Early 2011)

2.2 GHz Intel Core i7

16 GB 1333 MHz DDR3

AMD Radeon HD 6750M 1024 MB

Regards,

Brett


#2

Here is an update. Seems things are working correctly now with the SD card plugged in and the following procedure (not sure why i need to do this).

Once I got the ESC to program correctly (took a couple of tries) when I restart the system the starboard motor wouldn't function with negative values. Opening and closing the diagnostic window fixes this and the starboard motor responds as it should.


#3