[SOLVED] Flooded the Electronics Tube

electronics

#1

Good Morning.

Please give me you advice:

We were testing the OpenRov 2.8 this morning when the strap came loose from the frame of the ROV. Our diver dropped into pool to grab the equipment. He took hold of an endcap. This end cap came loose and we flooded the tube with pool water (chlorinated). We unplugged as soon as possible (within a few moments of breach).

We have taken these steps, within 30 mins flushed the electronics with distilled water. Used pressurized air to blowout all the visible moisture. Disassembled the major parts and flushed them again with 99.9% Isopropanol. Used pressurized air again to dry again.

I am planning to put (visibly) dry components in bags with desiccant as soon as they are blown out.

Is there any other advice on trying to mitigate the damage?


#2

You’ve taken pretty good steps so far. When you say you’ve disassembled the major parts, make sure that you take the electronics fully apart- take the BBB and the homeplug adapter off of the controller board, and the RJ-45 cable off as well. The isopropanol flush should have a low enough viscosity to get into all the connector sockets to dry them out. Also, on the camera, unscrew the lens and check for moisture in the lens holder.

While flushing stuff, make sure you flush out the electronics endcap with the DB-25 connector! That endcap is the hardest single piece of the ROV to replace (it’s pretty much the heart of the ROV), so it’s important that it gets rinsed and dried as soon as possible.

Packing components in desiccant is OK, but you might want to also try an oven. Start up the oven, set it to as low a temperature as it will go (maybe something like 170 degrees F), and wait a bit for the oven to stabilize at the low temperature. Then pop all your electronics in the oven. The high heat will evaporate any residual moisture much faster than desiccant at room temperature will. You might want to leave the oven door cracked to allow moisture to escape.

The reason I say to wait before stuffing things in the oven is that some ovens (mine, for one) will overshoot in temperature when they start up. You don’t want to melt the plastic pieces in the electronics!

Let us know how things go.

-W


#3

Thanks for the timely reply, Walt. Got the BBB and the home plug, but good point on the DB25. I will treat it promptly! Any words of advice of how long you would run the warm oven?

I noticed moisture was under the labels shrink tubed to the motor controllers, so I removed that plastic to dry that component. Should I replace the shrink tube before I reassemble the device?


#4

I don’t think there’s any rush on the electronics. Might as well leave them in the oven overnight.

As for the shrink tube, I have had to remove it at times before, and have replaced the shrink tube with Kapton tape. You could just use electrical tape as well.

-W


#5

Thanks again. I really appreciate it.


#6

OK. We saved most of it. the only issue is the depth prop. It chatters but never turns in either direction. Does anyone have ideas on where to start looking?


#7

It sounds like you might have a broken winding in the motor. Here is a picture of what a disconnected winding would look like.


#8

Thanks for the reply Brian. I have inspect the motor and I cannot see any breaks in the windings. Any tips on testing continuity?


#9

It seems like you are sure that this is in dependance of the flooding. This would lead to the conclusion that the thruster failure is related to an electronic issue. You may try to rewire the thruster, so that you can control via a different ESC. This way you can determine whether it is more a problem with the thruster or with the electronics controlling it. Hope this helps!


#10

That’s a good idea Fe3C.I will look for a wiring diagram of the 2.8 online. Unless someone knows the link.
-kN


#11

For anyone reading: this appears to be the repository: https://github.com/OpenROV/openrov-electronics


#12

I believe I ordered the wrong ESC. Oh my…

On Hobbyking I ordered the Afro ESC 12Amp OPTO UltraLite Multirotor ESC V3 (SimonK Firmware) - http://www.hobbyking.com/hobbyking/store/_64209__Afro_ESC_12Amp_OPTO_UltraLite_Multirotor_ESC_V3_SimonK_Firmware.html

Which appeared to all specs listed as the BOM part Afro ESC 12Amp OPTO UltraLite Multirotor ESC V3 (SimonK Firmware) -http://www.hobbyking.com/hobbyking/store/__64209__Afro_ESC_12Amp_OPTO_UltraLite_Multirotor_Motor_Speed_Controller_SimonK_Firmware_3

When I started to install I noticed the first part doesn’t have the POWER wire on the servo connector. (You probably heard my sigh across the planet). On the Hobbyking site it shows it this wire on both parts. So with the same specs and image I just assumed…

Can I use the former? IS it the same as the latter part with a different connector?

Thanks…


#13

@kidneutrino,
Unless OpenROV 2.8 design is using the ESC BEC to help power the Controller Board, which I highly doubt, the missing center power wire on your new ESC should not be a problem.
Regards,
TCIII AVD


#14

Thank you, TCIII.

More troubleshooting notes:

  1. I tried to switched Servo plugs on the STBD and VERT motors and I can activate the VERT motor with the arrow buttons. I soldered a new servos connector (3 wire) to the questionable ESC and it won’t boot.

  2. Once the new ESC is installed: If I hold the Shift for long enough ( about 5 seconds) this new part will boot and motor turns at full speed when I release the shift key and stops when I hold the shift key.

Any further advice /ideas?


#15

Another question: DO I need to reload firmware after replacing the ESC?


#16

You need to load the firmware onto the ESCs if you replace them. The ESC’s (electronic speed controllers) don’t share the same firmware as the Arduino on the Controller board.
In order to flash your ESC’s manually, follow these instructions:

Download PuTTY. It is a program that allows you to manually connect to an IP address via a terminal window.
When you run the program, connect to the IP address: 192.168.254.1
If there is no connectivity issues due to hardware, or your computers static IP address, it should open a terminal window.

login: rov
password: OpenROV

Type in the following lines of code:

cd /opt/openrov/cockpit/linux

sudo bash install-afro-esc-firmware.sh


#17

Thank you for the directions @Brian_Grau. I am giving it a try this hour.


#18

WooHOO! Thanks all. https://discourse-cdn-sjc1.com/business6/uploads/openrov/original/2X/4/44dab2d176795e18c74be7146db2c55092797081.mp4


#19

Glad to hear that everything is working well :slight_smile: